Help with mate-terminal, 256 colours & launchers!

So I have a slightly strange problem regarding launchers and mate-terminal. I know there are issues with using the ‘application in terminal’ setting defaulting to xterm, but this is about using ‘mate-terminal -e …’ and getting 256 colours.

Essentially I have mutt using the solarized colour scheme which requires 256 colours. This works if I set

export TERM=xterm-256color

in .bashrc

If I open the terminal and type


I see the colorscheme in 256 colours

If I open the terminal and type


then type


in the terminal that comes up, I still get 256 colours.

However, if I type

mate-terminal -e mutt

I get a slew of errors about colors:

Error in /home/d/.muttrc, line 62: source: errors in /home/d/.mutt/mutt-colors-solarized-master/mutt-colors-solarized-dark-256.muttrc.
source: errors in /home/d/.muttrc

The same happens if I use a launcher. Any suggestions hugely appreciated! I’m going to see if gnome-terminal helps me in the interim.

Hi @dm319, I’m curious what happens if you workaround that infamous “Application In Terminal” launcher with this technique:

I’m thinking avoiding mate-terminal -e... altogether may work.

Of course this doesn’t answer why -e has issues. Perhaps it has something to do with default profiles.

Yes, seems like it did the trick. All I did was install gnome-terminal, and have ‘application in terminal’ on the launcher - now it works fine - both from the applications menu and from synapse! Bit of a fudge, but it’ll do!

Well that’s yet another way. :slight_smile:

My idea was to make a symbolic link named gnome-terminal pointing to mate-terminal because Application In Terminal looks through a priority list of terminal programs to use, finds this fake gnome-terminal link (before xterm in the list), so ends up running mate-terminal. Nothing need be installed.

This technique works well to make Application In Terminal use mate-terminal.

Both are fudges but the bottom line is you got it going with real gnome-terminal.