Hide Windows Not Working

Whenever I minimize my browser (Vivaldi), and then open my email, my browser closes. I have to reopen it. The icon for hiding windows in lower left of the screen doesn’t seem to work. Or am I not using it correctly?

Do you have the window list widget on your bottom (or upper) bar? It may just be that you can’t see the application is open because the widget isn’t added.

(I’m assuming you haven’t alt-tabbed to try and get it back, if you have, and it’s not there, please give us a little more information on what specifically you are doing.)

  • Does it happen with other web browsers as well?
  • How do you open your email and what program do you use to open your email?

If you mean the thing that looks like a file symbol, yes, I have it. I have the panel on the bottom, not the top.

Here’s what happens: say I have my browser open. I minimize it and open my email. When I click on the widget, nothing happens. If I click on my browser symbol, it opens a new instance, the old one is gone.

I’ll have to try the ALT/Tab thing. Can’t do now as I’m on a different distro.

It happens with any windows I have open. Minimizing them causes them to be closed.

Open Mate Tweak and change the compositor.

Does it happen with all of them?

I don’t think you have the task switcher widget on your panel. The reason I say this is because I was mistaken by this behaviour too a while back. The “file symbol” widget simply minimises all windows, at which point, if you don’t have the task switcher widget on your panel, it looks like the app has closed.

Can you right-click on your panel, and add the widget, (I’m not as my desk right now but I think it’s the one called Window Switcher or task switcher. There is no specific icon for it when you add it to the panel, however it will then show up all open applications.)

Yep, that did it, Broken Canoe. Thanks, you solved it. This distro is so sophisticated, it’s going to take some time for me to really get to know it. It’s completeness never ceases to amaze me.

1 Like

Good to hear :blush: There’s a heap of room for customisation, and even more to explore. It’s worth your time though. Enjoy the journey!

Oh no, what have I done? I have added two of the widgets. So now whenever I open something, I have two widgets telling me it’s open. I can’t figure out how to remove the extra widget. Is it possible? Maybe reset to default?

You should be able to remove it. Can you do a right mouse click on the widget? Does it give you any options?

No need to reset to default, just right click on the very edge of one of the widgets and choose "Delete This Widget"

Got it! You need to click on the little vertical line and that brings up the menu which says “remove from panel.”

Thanks again, Mr Canoe.