Home network file sharing

What’s the best way to set up file-sharing on a home network?

I’ve scoured the web, and tried many suggestions found there, but nothing seems to work. The file manager – caja – displays no Share option, though it’s apparently supposed to. Nor does Nautilus.

At the moment it involves two machines, both running Ubuntu 15.04 Mate, but I’ll also be needing to share with visitors running Windoze 7 and Kubuntu 14.04. WiFi or EtherNet connections.

Install samba from the software centre

Then open samba (it’s in the system/administration menu)

Click on the plus sign button and browse to a folder of choice

Make sure you select “visible” and “writeable” if you wish to give users that right.

Also, for simplicity’s sake “allow access to everyone”.

However, I have found that it also is a good idea to then go into the samba conf file and and add to the bottom of every shared network location entry:

force user = username

Where “username” is your actual username

You can find the smb.conf file in


To open it for editing, you need to right click it and open as administrator

An example of the kind of entry you will find (at or near the bottom of the file) is:

path = /home/stephen/Documents
writeable = yes
; browseable = yes
guest ok = yes
force user = stephen

Once you have done all of the above, restart your machine and log back in. You should now find your folder is visible on the network.

You can tighten down the rights of individual users to access shared network location, but the above will get you going with a basic setup.

Finally, you may have already guessed that a GUI is not really necessary since you could have, if you’d wished, simply gone straight into the smb.conf file and written out your shared location entries in full. The advantage of the GUI, though, is that is does most of the work for you

Thank you, Steve. I’ve got it working now, though I didn’t get any GUI when I opened Samba, and the conf file doesn’t look much like the examples you gave, For instance, there’s no “force user =” entry, or anything like it. But no matter – it works. On one machine I see Share Options when I right-click on a folder in caja. On the other I don’t. Both running Ubuntu 15.04 Mate with Samba. Bit of a mystery.

I’m using commands like this to create Shares:

net usershare add documents /home/weyland/Documents "weyland documents" everyone:F guest_ok=y

Seems to work fine. (Haven’t tried Windoze yet.)

To enable the share option in Caja you need to install caja-share. With this there will then be a Share this folder choice on the Caja drop down menu and a folder can then be shared with a click of the mouse.

Funny how the forum itself suggested this very old thread !!

Looks like lots & lots of changes since this thread was made in 2015 !!

None of the pics here resemble anything I've seen in 18.04 and there is nothing like the 'software centre' mentioned here anymore ?!?