How to change font on login screen?

I’ve changed my font but it doesn’t seem to have any effect on the login screen, it still has the default Ubuntu font…

Anyway to solve this?


pkexec lightdm-gtk-greeter-settings

and change the font there. (I found it with my launcher Albert, but it doesn’t appear for me in Brisk or Control Center. It’s possible I hid it though.)

Do I have to install the launcher?
From the terminal the command doesn’t work!

Sorry, I did check that it worked, but I never made sure it was installed by default. I don’t remember installing it, but it looks like either I did or it was installed with an earlier version of Ubuntu MATE and stayed around during the upgrades.

I think you just need to

sudo apt install lightdm-gtk-greeter-settings

to install it first.

I thought that since the switch to slick-greeter a different method of customising the login screen is used.

I’m not sure what you’re “supposed to” use. Based on the manifest, 18.04 includes lightdm-settings, but when I opened that I didn’t see any option for changing the font. When I used the other tool, the font option is there and it did change for me.

@elcste, after installing just you said, I'm getting this entire new type of login screen:

And I can't seem to find the font I'm using on the rest of the system(Source Sans Pro) in the settings! In fact, none of the newly installed font is there!

Perhaps this will help -

The information here is a bit outdated but will help you in getting your new fonts available system wide. Good luck Apollonius.

1 Like

I didn’t get that when I tried it, but likely because the configuration is different since my machine was updated from older versions that used different greeters. I’m guessing it installed lightdm-gtk-greeter as a dependency and set that up. You maybe be able to reconfigure lightdm

sudo dpkg-reconfigure lightdm

or you might need to remove lightdm-gtk-greeter or reinstall slick greeter.

For the missing fonts, my first guess is that they’re installed in your user directory. They need to be installed system-wide for the greeter to see them.

Yes, from the wiki article above, I guess I need to install it manually for system wide effect.

And I uninstalled lightdm-gtk-greeter-settings, but the old login screen isn’t coming back.
UPDATE: Uninstalled the lightdm-gtk-greeter and reinstalled slick-greeter and it’ll alright again.

Speaking of system-wide font installation, the already pre-installed fonts should be installed system-wide right? But even they don’t affect the login screen!

I was just going to post that I tried it in a live session and got it to work the same way.

This I don’t know.

Hope this helps: A quick search for “slick-greeter” on the forums reveals some threads about it and how to customize, among them:

1 Like