How to check for malware?

system

#1

UM 18.04
FF 61.0.1

Hello, For the last week or so FF has been really laggy…Example, when I type a letter in LO Writter it takes about 6 seconds for that letter to show up on the page. Typing in the Search field does just about the same thing.

Pages will load, I scroll down, and then jumps back to the beginning (top of page), as if I just arrived at that page. I scroll down again and then the page might freeze for a couple of minutes.

I updated the Kernal to 4.15.0-30-generic, I thought that was the problem, but no it wasn’t.

When I use Google Chrome, I get the same sloooooow responce when typing in LO Writter.

Be gentle…I’m old and ill equipped for this e-World. LOL

Thanks. Any help is appreciated.
mt


#2

It almost sounds like a low memory problem. What kind of hardware do you have? Have you done anything odd with swap memory?


#3

Hello Grandpa :smile:

So i had some problems with FF too, at least there is where seemed to start.
Check out this topic, maybe your laptop needs a cleaning:

It did wonders for me.

Good luck


#4

With respect to the memory, if you open a terminal and type
free -h
and post the result here, that would give us some idea of your memory usage (the -h bit is just a personal preference for readability)


#5

I experienced this under FF, what you are experiencing is not malware - You’d be hard pressed to get a malware infection under Linux. It’s like a lag when you’re typing in FF.

I’m not too sure what rectified my issue, but it seemed to go away when I swapped keyboards.


#6

Hi Jason I have never messed with swap memory... I wouldn't know what to do with it.

See screen shot... Taken a few hours ago.

Thanks


#7

Hello karnemelk, I’m using a desktop computer. Sorry, I should have mentioned that.

Thanks


#8

Hello Plutocrat, Here's a screen shot.

Thanks


#9

Hi Jason, Forgot to send you my hardware list:

Motherboard - M5A78L-M LX PLUS
CPU – AMD Athlon™ II X4 640 Processor
Memory ----7,975.3 MB SWAP – 2,048.0 MB
Available — 2,048.0 MB Used – 0.0 MB
Used — 1,567.1 MB Sin — 0.0MB
Free — 128.0 MB Sout — 0.0 MB
Active – 3,251.6 MB
Inactive – 3,310.2 MB
Buffers – 1,263.1 MB
Cashed – 4,996.7 MB

Graphic – Advanced Micro Devices, Inc. [AMD/ATI] Turks PRO [Radeon HD 6570/7570/8550]

Sorry

mt


#10

Okay, so that was the obvious “is it definitely plugged in?” type question. If you have already tried turning it off and on again as well, then may be moving out of the realm of “simple”. This class of machine should not be exhibiting that behavior, and I would be surprised if something like malware could cause it to behave that way. Driver problem? Something went weird with the hardware?

Anyone have suggestions for troubleshooting? I would probably back up my files and try a reinstall or another distribution to see if I can affect the problem - but that is an extreme solution.


#11

Hi Jason…Thanks I’ll wait and see if someone has an idea.

mt


#12

Did you try to start FireFox without your addons/extensions enable? It might be one of your addon which got a bad update or is not anymore compatible with the version of your FF.
I would start Fire fox without its addons and then enable them one by one to see if it’s not an addons/plugin.
tape in the address bar (url field)
about:addons
then Press Enter key to see all your addons, extensions and plugins to disable them

Are you using LO online via Firefox? I am confuse here…
If not, About Libre Office i would try to uninstall it (via CL purge or Synaptic Package Manager), reboot the computer and re-install LO.


#13

Hi Patrice,

I did disable my add-ons and rebooted. There was no difference in UM performance.
Also, I have LO installed. Just now as I was typing here, it took about 10 seconds for the letters to appear in this message. I don’t believe it is a problem with LO. As someone mentioned before, I think it’s maybe a hardware issue.

Thanks for the help…

mt


#14

In “Software & Updates” on the tab “Additional Drivers” what are you using? (screenshot?)


#15

It is possible that only your internet speed slowed down. I had the same experience like this with a pretty slow internet connection.

Pages will load, I scroll down, and then jumps back to the beginning (top of page), as if I just arrived at that page. I scroll down again and then the page might freeze for a couple of minutes.

I actually do not think it’s a hardware issue. Your performance is good besides FF, isn’t it?
If the internet connection is not the problem I would make a backup and do a fresh install UM 18.04.1.

Mickey :slight_smile:


#16

Hi Patrice,

Here is what is used. This has been the same since I installed UM 18.04.

Thanks for the help so far.

mt


#17

You got the same as me (no options about proprietary drivers) , I am sorry but from here I have no more ideas to help you :cry:


#18

Have you got another keyboard? I know it sounds crazy, but I had your exact issue with laggy typing under LO and FF and I swear changing keyboards is what fixed it.


#19

I can understand the previous suggestions about checking free memory, because Firefox has a reputation for maxing out RAM usage and slowing to a crawl, but since you are also seeing slowdowns in Chrome and Libre Office it’s likely NOT a Firefox specific issue.

I suppose that you could have picked up some kind of browser related plugin malware, but if so, it should show up as either a plugin or extension under your Firefox “Add-ons”, and you can easily see if Firefox is hogging system resources and slowing things down by simply rebooting and trying other applications BEFORE loading Firefox to see if they speed up when Firefox is not running.

From your description it sounds like ALL applications are lagging because they are getting bogged down by some MATE system related compatibility issue.

You can check if something is maxing out your CPU by opening the “Mate System Monitor” under your System Tools, and clicking on the “Resource” tab, which will show both Ram and CPU utilization, with the individual CPU loads for each core. If your CPU cores are maxing out, you can identify the culprit by opening a Mate Terminal and typing “top” without the quotes (type “q” and close the terminal to exit). If things are lagging and slow, but nothing seems to be overtly hogging 100% CPU, then it’s almost always a kernel or low level driver issue.

If I had to guess, I would say that you are probably being hit by a pulse audio, bluetooth, or video driver related issue, related to UM18.04 compatibility on your specific hardware.

Here are some simple things you can try:

Disable Bluetooth (if you are using a bluetooth keyboard, try a USB keyboard instead)
Disable WiFi
Disable Pulse Audio

Don’t worry, I’m not suggesting that you should accept that you will have to run MATE without these important features, just that you might want to disable them temporarily for troubleshooting.

Another thing to try is to open the “Mate Tweak” tool and change your window manager.

I have found that usually when there is a slowdown, it’s related to a compatibility issue related to a driver update, or system library change, so the first thing to do is try to isolate which driver or library is causing the problem by trying to narrow things down a little. WiFi, Bluetooth, Pulse Audio, and Video Drivers are all good possibilities, because they all run at high priority, and can easily hang or slow the system if there are problems.


#20

Hallo

Where you are right now, I’d try a fresh install - backup your stuff first! :penguin: