How to close all sessions in Xrdp . Problem with drives

Hello guys ,
I have a Windows domain and I just joined an Ubuntu Pc in it . So to have a remote access on it , I installed Xrdp and Mate . Everything worked great and I worked in different sessions ( I had the port -1 on) until the time I inserted a usb drive on the Ubuntu pc . Multiple errors featured but they had the interface of mate ( So it was clear that the errors were caused from the already open sessions) . The messages-errors were :
a) Unable to mount Chris(F:)
b) Unable to open in terminal

In addition , the tab with the index of the flash drive appears 3(!) times .
I think the problem is the other open sessions. How do i close them . I need help.

Hi @Lenos_Adamou,

does this help at all? (see @lah7’s post!):

You could restart the service, which would essentially “kill” any other sessions that are running.

sudo service xrdp restart

I’ve done this many times …

I’ve done it… Nothing happened

I don’t actually use XRDP anymore, but I do recall there have been permission issues with more system-wide behaviours like configuring a setting or mounting drives. This happens regardless if there is another session running or not.

Since you’re just mounting a drive, try manually mounting it instead of letting Caja auto-mount it:

sudo mount /dev/sdXY /mnt

(Use GParted or sudo fdisk -l to identify the /dev of the device)

Alternately, I’d recommend using X2GO instead, which I think is a superior alternate to X2GO for Linux remote desktops over a network if you don’t need RDP compatibility. The server/client is available to one-click install from the Software Boutique. It has a Windows client too.

A post was split to a new topic: X2GO not working in Ubuntu docker container