How to get Tor browser icon to show in Plank?

I started using Plank. When I open Tor Browser it only shows the regular Firefox icon in Plank but not the Tor-specific icon. Does anyone know how to fix this?

Maro

I have not used plank much before, so we are going to have to sort this together.

I started Plank and this is what it initially contained:

I went into Plank's settings to see if I could add Tor, but couldn't find anything. I then fired up Tor from the main menu and it opened, but it did not appear on Plank.

I then opened the main menu and dragged and dropped the Tor icon from the main menu onto Plank. That worked and this is what Plank then looked like:

Also, when I closed Tor, the Tor icon remained on Plank. Presumably permanently until and unless I manually remove it.

So, it appears to be working for me. Did I do it in a different way to you? Or are you wanting it to behave in a way I have not understood?

1 Like

Further to the above:

I deleted Tor from Plank. Then went to open Tor from the main menu again. This time, weirdly, it showed on Plank and with the correct icon.

See below:

So, to reiterate exactly what I did and in what order:

  1. Started Plank

  2. Started Tor from main menu. Nothing extra appeared in Plank

  3. Dragged and dropped Tor icon from main menu onto plank. At which point correct Tor icon appeared on Plank. Also started and closed Tor from Plank. Tor icon remained on Plank after closing Tor.

  4. Deleted Tor icon from Plank

  5. Started Tor from main menu again and now correct Tor icon appeared on Plank. Closed Tor and Tor icon disappeared from Plank

Thanks so much for taking the time to help solve this problem @stevecook172001 and @marfig (I believe you posted a comment last night and I wanted to reply the next morning). I reproduced steps 1 to 4 and the icon behavior is exactly as you described. The correct Tor icon appears on Plank. I am not sure why step 5 doesn’t work for me. When starting Tor from the main menu only the usual Firefox icon appears.

Did you perform step 5 independently of steps 1 to 4 or did you try and perform it in order? That is to say, immediately following steps 1 to 4. I only ask because I am trying to ascertain the specific circumstances when it is or is not working.

I tried to perform it in order, that is, step 5 followed immediately after step 4. I also had all other Firefox instances closed and only started up Tor browser. It really seems to work on your machine. Let me try this procedure on another laptop.

I should also say, since posting my last but one post showing steps 1 to 5, I have switched off my PC and then, this morning, come back onto it. I have consequently just opened Plank and then, from the main menu, opened Tor. It has then appeared on Plank as a newly opened application, as it should. It also disappeared when I closed Tor down. Again, as it should. So, it seems that, for whatever obscure reason, performing steps 1 to 5 last night has put in place a permanent recognition in Plank of Tor’s presence.

My guess is that putting Tor manually onto Plank in step 3, however temporarily, somehow caused some kind of permanent change in Plank’s configuration that fixed the original problem. But, this is entirely speculation on my part.

I use the Cupertino layout panel, so Plank is permanently available. Maybe Plank is configured differently as part of Cupertino than when started separately? Yesterday, I also closed Plank (but my desktop configuration was still set to the Cupertino layout) and restarted Plank with the same failure in step 5.

ahhhh…that’s interesting.

You may have hit on something there.

Try it with the standard mate layout.

For your information, the precise setup I am using is standard mate layout, marco without compositing and Compton compositor running independently with my own custom comton.conf file.

So, as you say, I am running Plank independantly

I think I found the problem. I went through nearly all configurations. It seems that it is not related to window managers or panel layouts but the Advanced Menu. With the Advanced Menu activated via Mate Tweak only the Firefox icon will show in Plank. With the regular menu (Applications - Places - System) everything works fine and the Tor icon is correctly displayed in Plank. Can you confirm this?

Yes, I can confirm this Maro. So, that appears to be the problem. As an aside, in changing to the advanced menu, I have just lost all of my panel customizations!..:weary:

Never mind, I can re-create them without too much bother

Ahh, I should have mentioned it earlier. Sometimes I forget this too and have to adjust all my panel customizations again. Thanks for keeping me motivated to track down this problem. This is one of the amazing things about this community and people like you. Now that we've identified the problem, I wonder if someone knows of a solution (I prefer to use the Advanced Menu). Is it really related to Tor as @wizd3m has previously suggested or are the MATE Tweak settings of the Advanced Menu overriding the Tor icon set?

I was also wondering if the problem is somehow related to Mate Tweak as opposed to Tor and/or Plank. In the end, it is a moot point anyway. If the problem can be fixed by Mate devs without too much disruption, then that would be a good thing irrespective of origin. I suppose it comes down to priorities. It would be entirely understandable if fixing a minor issue like that was put low down on the list of things to do.