How to stop automatically maximazing window


#1

Hello,

I installed ubuntu mate 14.01.1 on Dell Latitude E7250.

When moving a window (by holding and dragging the window top) to the left or right of the screen, the window automatically maximazes. How can I disable this? Thanks.


#2

You can disable window-snapping under Control Panel > Windows > Placement. Just remove the tick at Enable side by side tiling.


#3

This feasture is disabled on mine. I wonder if that is becasue compiz is enabled? If so, do you know how I could disable the window snapping feature in compiz because I am not fond of it either.


#4

Thanks wizd3m. It works.


#5

You can also simply drag the hand (mouse cursor symbol) downwards when it is in full-screen and it will go back to its original start size.


#6

Yes, but I don’t want it to automatically go to full screen when I drag it to the top of the desktop in the first place.


#7

Hi,

basically drag it to just under the top panel and it won’t go to full screen!, the other choice is Control Center > Personal > Windows and play with the settings there:


#8

Those options in that panel are for when the title bar is double clicked. I want the window to maximise when I double click the title bar. I just dont want it to maximise, either partially or fully, when I drag it to the top or bottom or to either side. Or, at least, I wish to have the option of enabling/disabling that feature.


#9

Hi Steve,

try CompizConfig Settings Manager > Window Management and disable Resize Window and maybe Grid?:

Hope it helps. :grinning:


#10

@stevecook172001 If you’re running Compiz, use CCSM and untick the Windows Snapping plugin.


#11

I’m not using compiz


#12

I dealed with this problem. too.

~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION=“Ubuntu 18.04 LTS”

using MATE tweak can stop did stop the menu from maximizing,

System > Preferences > Look and Feel > Mate Tweak > Windows
Checked box: “Do not auto maximize new window”

But that setting did not stop them from growing top to bottom on one side of the screen or from side to side covering top have or bottom of screen.

~$ sudo apt install compizconfig-settings-manager

then launch compiz config settings manager and uncheck the box at grid.

now no more widows growing automatically.


#13

this action came back again.

~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.1 LTS"

Now launch compiz config settings manager and uncheck also the box at Window Management > Snapping Windows.

Then it stopped again.