HP EliteBook touchpad works different after it comes back from sleep

Hi, I’ve been trying to setup the touchpad on my HP EliteBook but it has not been an easy task.
If I open the Mouse settings, there is no Touchpad tab there.
Trying to set it from the terminal is like I’d do nothing.
I am on Ubuntu Mate 16.10.

For example I hate tap-to-click. Especially that feature that, if you double-tap fast, it emulates a “keep it clicked” state and I just start selecting stuff or just can’t control it very well. I also would like to disable the touchpad while I’m writing, and I’d like to reverse the scroll direction with the two-fingers touch.

Thing is… I have noticed that all these behaviours disappear after a sleep -> wake up transition.

It’s like if it loads some different drivers or settings.

How can I debug this problem and find a way to make the laptop boot up with the “after woken up” settings? :stuck_out_tongue:

Thank you for your time

Do you have synaptics touchpad drivers installed ? Becouse Mate doesn’t have libinput support in 1.16 release and previous , and that may be the reason for odd behaviour and missing touchpad configuration options .

I have both synaptics and libinput installed.
Just to be sure we are talking about the same packages, could you please
write their names?

The synaptics touchpad driver :
And there is no way you wouldn’t have libinput since it will break the xserver .

I can confirm I got that package and xserver-xorg-input-libinput both installed.

When the laptop comes back from sleep, I notice that the touchpad device gets mapped to a different point.

I’m going to show the results of two dmesg outputs, each after a resume:

➜ ~ diff dmesg1.txt dmesg2.txt | grep input
[ 458.142294] input: AlpsPS/2 ALPS GlidePoint as /devices/platform/i8042/serio3/input/input27
➜ ~ diff dmesg2.txt dmesg3.txt | grep input
[ 961.342385] input: AlpsPS/2 ALPS GlidePoint as /devices/platform/i8042/serio3/input/input35

Can this help solving this problem? Is there a way to force that remapping? Maybe that would save me from doing a forced sleep-resume.

I have upgraded the system to version 17.04 and now I don’t have the possibility to get my “favourite” behaviours after a sleep/wakeup session. It stays the same as before the sleep, so I can hate it 24/7 :stuck_out_tongue: