Hplip missing files

Hi Chris,

did you make the 2nd entry default printer?, otherwise it may address the first entry only!. :thinking:

Bad to worse im afraid, it is not letting me add the second printer now it is showing "requires/usr/lib/cups/filter/hpps" program that is not currently installed.

I have to call time on this for a while i`m afraid I have to do some work I will return later.

Hi Chris,

it states in the following link that "hpps" is included in the "Class Driver Package" which is the package "hplip" afaik, take a look at the links which may prove useful to you.


You could try re-installing the package?. :thinking:

Hi Wolfman,
I have managed to get both printers working, not as would like(I could not install them as network printers) but hey ho. I booted into a live cd just to see if I could install the printers. No need to add them as they were recognised straight away and worked fine.
I have since found out that HPLIP is not supported in 20.04 because of possible dependency issues so it may be wise to wait for a .1 release before trying to do anything more with it.
Longer term I will move my home partition onto a large ssd and just put the OS onto another smaller one so if I need to upgrade in the future it will be less of a pain.

1 Like

Hi Chris,

I installed my printer using HPLip GUI and it found it no problem, looked in Control Center > Printer and added it there, there were two entries, had a problem deleting one entry and did a restart to find there was only the entry I set to default showing. Started HPLip GUI and then it said
"Device is busy, powered down".

Closed HPLip GUI and opened a text doc and it printed okay. The problem might lie with "HPLip GUI" but I am not sure???.

Screenshot at 2020-05-12 16-11-34

So I guess the moral of this story is not to use HPLip GUI????????.

Stay safe mate. :+1:

Hi Wolfman

Thanks for the update, interesting that you also found it not to be that straightforward.

I have tried digging deeper to try to fathom it out but to no avail. I have never had any trouble with HP printers in fact I have been using them from 14.10 onwards usually downloading the latest .run file from HP and installing via the CLI. When asked by the device manager which option to install I always clicked on the Network method and manually put the static IP addresses of my printers in. Having found them on the network it installed the plug-in and that was it, no problem!

Using this method in 20.04 brings up the error message that HPLIP is not supported in 20.04 but it also offers to install using 19.10 dependencies, of course they may have been removed from the repository to the best of my (limited) knowledge in 20.04. I would assume that this is why all the errors about missing files kept appearing.

As I said in the previous post they are both working now as I have just let the OS β€œfind” them and left it at that. I have noticed that when they were installed using the static IP addresses they printed almost as soon as you clicked on the print button but now they are taking an age to process before printing. From this I would assume that there is a definite bug somewhere when trying to add a printer using the network method but am hoping that somebody with far greater knowledge than me (i`m 66 and flagging a bit) will be able to fix it.

Keep well stay safe

I'm 65 and about the same as you LOL!. :rofl:

It might be that HPLip GUI simply isn't compatible with Ubuntu 20.04??????. Let's hope they bring out a new version in the not too distant future!. :grinning:

Looks like I will have to update the HP printer guide that I created a few years ago!. :thinking:

Flag it as solved if you are satisfied that things are okay please and that will help others. :innocent:

1 Like

Hi Chris,

if you ever have a problem with a missing package, one of the best places to look is on the following sites, it has saved my sorry "A" a few times in the past!.



https://pkgs.org/ :grinning:

I also noticed that the original HP printer guide that I wrote is from 2015 and could now do with an overhaul, I should reference this thread in it too to help others!. :thinking:

Hi Wolfman,
Thanks for the tip it looks like a useful site to have as a backup to google :grinning:
I have called time on trying to do anymore with it as the missing dependency is Python 2 which has been dropped in 20.04 in favour of Python 3. I will await a fix as it has already been flagged as a bug.

Note to self, always wait for the .1 release :tired_face:

As of today we cannot install hplip-3.20.3.run on Ubuntu 20.04 LTS because of missing Qt4 dependencies. It is already reported as bug 1876205. We should not do everything with this, I think. Just need to wait for fix from HPLIP developers.

But deb-packaged version ( sudo apt-get install hplip-gui ) should work.

HP have released HPLIP 3.20.5 with support for 20.04 but when installing it is still not working due to the missing Qt4 dependency.
I have filed a bug report

1 Like

A couple of weeks ago, I successfully installed an HP M29w laser jet for use on four systems – two running UM 18.04 and two running UM 19.10, all employing hplip 3.20.5. The device worked via wireless and via usb connections. I could print and scan (using VueScan). Yesterday I upgraded the two 19.10 instances to 20.04, and everything went very well except this printer. I wish that I seen this thread before I upgraded.

After many attempts to get the printer to work using hplip 3.20.3 and 3.20.5, I can only use the printer via wireless. No scanning or printing via usb. The symptoms are well documented earlier in this thread.

So, I am not writing to grouse. I want to offer to help test a final solution. I am not a developer, but I do have some time and would be pleased to help. Both potential test systems are 64-bit Intel-based systems from System76. (I really like UM and I appreciate the efforts to create and maintain it.)

1 Like

Have been frustrated by still not being able to scan using my HP M29W device using UM 20.04. Reached out to VueScan software support (https://www.hamrick.com ) and got the following suggestion that has made scanning work again under most situations. (HPLIP/UM still seem to be broken, however, and I hope for a solution in the near future.)

  • sudo apt purge ippusbxd
  • then check that libcanberra-gtk-module and libcanberra-gtk3-module are installed

Having done these things, vuescan can be run successfully. Sometimes when multiple usb connected scanners are present there are troubles, but most times scans work.

Perhaps this will help others until a real fix is available.

I can understand your frustration as I have still not been able to get my HP MFP to work as before.
It begs the question that there is obviously an outcome as many people have used VueScan and it does work in the Linux environment.
Perhaps the community should fund someone to fix this ages old problem and get this printing problem sorted once and for all.

Interesting idea. If funds would help, I'd be glad to contribute.

Yesterday I replaced my system disk with a new one. Installed 20.04 fresh with partitions for swap, / , and /home. After that printers scanners seem to work better, however, HPLIP is not installed by default and I am not going to install it until/unless a new HPLIP release is made that explicitly supports 20.04. BTW, ippusbxd is not installed by default.

I think that at least some of my scanner problems stemmed from two things - (1) I have for some time done upgrades and not fresh installs; (2) At one point I tried to install HPLIP without carefully reading the release notes that indicate that 20.04 is not supported.

So, I have to accept some responsibility, but I think that it is surprising that HPLIP and 20.04 have not been made compatible. I hope that this happens.

Applications that scan properly are VueScan, scan2pdf, and "document scanner." Devices that work are the HP29W multifunction (usb scanning and wireless & usb printing), and an EPSON WF-4720 multifunction (wireless printing only), and an EPSON usb V370 scanner.

And, BTW, my first attempt at a fresh install of 20.04 failed! It encountered a known bug associated with 3rd party s/w installation during the process. I got around this by loading third party software (nvidia driver) after a stock install finished. This is the first time that I have seen such an installation failure.

I'm done with adventures for a while. Back to doing "real work."

I have now given up with my MFP and have a HP colour laser and a Xerox B&W laser both being driven driverless over my (hard wired) network. I must say that it works well not having to rely on manufacturers drivers and all the grief that comes with it.

I have just paid a visit to the HP developers page and found the following,

Release Notes

HPLIP 3.20.11 - This release has the following changes:

Added support for following new Distro's:

Ubuntu 20.10 Debian 10.6

Fixed issues:

Fixed usb print issue for ipp supported printers for Ubutnu 20.04, Ubuntu 20.10 and LinuxMint 20.04

Somebody needs to get a grip on this, until such time as these drivers work with at least some degree of success for the majority of users it is rather rash to claim that the operating systems mentioned are supported

I want to thank you for exchanging information about printers. I think that when I next work on my network I will try the approach you are using.


After months of waiting for a fix for this issue I have given up. Not for the want of trying the various solutions offered and the rollout of updated releases from the HPLIP developers I was still getting the now infamous "pyqt 5 missing" error.
My printer now running out of colour toner I decided for a few pounds extra I might invest in a new one and after hours of trawling for some information decided to go for a Brother HL-L3270 colour laser as there website contained plenty of information regarding Linux and the reviews from previous Linux users was positive
What a breath of fresh air!!!
Downloaded the driver install tool from the Brother website opened a terminal, two instructions later and I'm up and running. How easy was that, no problems and pretty good print quality.
Bottom line is that there is obviously an inherent problem with all Flavours of Ubuntu and HPLIP and until these are addressed people are going to vote with there feet and move away from HP.
I ran a live cd of the latest Manjaro Distro just to have a look and tried to install my HP printer, guess what, installed with no problem so this points the finger back to Ubuntu.
Any body who is looking for an easy solution would no doubt consider this as an option but fortunately I am a big fan of Ubuntu MATE and am staying loyal :smiley:

1 Like

I had the same problem with HPLIP when updating to Ubuntu 20.04.
I removed the printer and reinstalled it without HPLIP, that is to say, in the "add new printer wizard",
I choosed "via DNS-SD" (instead of default "HPLIP") as the connexion method.