I can't boot ubuntu on my lenovo 320


#1

im new to linux and i was hoping to try it out on my new lenovo 320 (intel atom x5) and ive been trying for days to boot ubuntu or any other linux distribution (old and new versions) but to no avail… any assistance would be greatly appreciated


#2

Hello
Please tell us more details about the situation:

Can you boot the live session?
Is there already an operating system installed on the machine?


#3

the current operating system is: windows 10.

im not sure about what you mean by the “live session” but the “try ubuntu, install ubuntu” is as far as i get, after that is a black screen and nothing afterwards


#4

Okay, how did you create your boot media? Is it a USB drive or a DVD?


#5

Also, does this post matches what you’re seeing?


#6

I i used SandDisk 8GB USB


#7

yes it matches it Exactly!


#8

Alright, most likely explanation I can think of is that the hardware is too recent and the kernel you’re using just does not know how to handle that weird screen.

My recommendation would be that you try the latest development image of Ubuntu MATE.
You can get the ISO here:

http://cdimage.ubuntu.com/ubuntu-mate/releases/17.10/alpha-2/artful-desktop-amd64.iso


#9

and the process is the same thing?
burn, boot and done?


#10

Yes, if at all possible you should also check the integrity of the .iso you’ve downloaded, the sha256sum should be as follow:

64c1f55e339874d9feaecf27a47255f32e212c455d66e82e57091248113f6fbf

Edit: see here on tips on how to do that:


#11

i will, thanks a lot for your help, always heard that linux community is a helpful one, now i know for sure :slight_smile:


#12

it worked… but its now sideways…


#13

This should be fixable from the display settings:

Edit: to open those settings, hit CTRL + ALT + T then type in: mate-display-properties


#14

it worked!! do you know how can i disable the touch screen?


#15

Sorry not sure, that’s some unusual hardware you’re using, maybe someone else will be able to chip in.
I’d recommend looking for a kill switch in the BIOS of the machine.
Something else, if when you’re trying to install you don’t see a hard drive you should also check the BIOS. Lenovo has been known to use dumb RAID settings on its hard drives (dumb because a RAID with only one drive has no point) using proprietary drivers that Linux can’t handle.

Lastly, if you decide to go ahead with the install and everything is fine, please consider posting your hardware specs in this thread:


#16

Tested booting up ubunto mate on a lenovo miix 320 and it booted fine!

To turn the screen from the command line:

xrandr --output DS-1 --rotate right

I checked the following subsystems:

  • wifi ok
  • sound ok
  • video (youtube) ok

My usb disk was mounted as /dev/sda .

lsblk shows the internal hard disk as mmcblk0.

Failed to mount the internal harddrive. Fdisk shows the windows partition as “Microsoft basic data”. But I fail to mount the partition:

$ mount -t ntfs-3g /dev/mmcblk0p4 /tmp/dosc
Failed to mount '/dev/mmcblk0p4': Invalid argument
The device '/dev/mmcblk0p4' doesn't seem to have a valid NTFS

I also have not managed to access the internal modem.


#17

Hi,

I’m also proud owner of a miix320. :slight_smile:
Unfourtenately my miix isn’t booting 17.10. I get the GRUB menu and Splash screen (in portrait mode). Once X is starting, the screen goes black, and stays that way.

Any hints on that?

Many thanks in advance.

Bastian


#18

Hello,

The disk image suggested by ouroumov I found under http://cdimage.ubuntu.com/daily-live/current/.
But the experience with my Lenovo MIIX 320-10ICR is exactly the same as Bastian: Black screen after choosing the live option. On OpenSuse I can give Commands to the installer i.e. “nomodeset” (still OpenSuse is also not installing).

Is that possible under Ubuntu, or any other idea?

Thanks


#19

Hi sic_vic,
It didn’t work for me but after some search it appears it worked for you thanks to a combination of

  • the kernel version you had with the alpha2 of the 17.10, probably a 4.10 or 4.11 that was upgraded to 4.13 in the release
  • and the firmware version.

It would be really nice if you could share your Miix 320 firmware version in order for us to know if we should upgrade (on Miix 310, apparently Ubuntu was only working with old firmwares), and if you could share a link to the 17.10 alpha2 iso, as I couldn’t find this preliminary version on the Internet anymore.

Thanks a lot, there would be more than one happy guy :slight_smile: