In 15.04 & 15.10 Omxplayer "vchiq" error

Hello.

I had 15.04 (installed via BerryBoot cause BerryBoot didn’t give the choice to install 15.10 directectly) and this same error that i still have with now that i upgraded to 15.10 ; when i try to use omxplayer i get the following error:

“* failed to open vchiq instance”

Well, i found http://raspberrypi.stackexchange.com/questions/19436/how-can-i-permanently-fix-dev-vchiq-permission-errors

And fixed it by doing

echo `SUBSYSTEM==“vchiq”,GROUP=“video”,MODE=“0660”’ > /etc/udev/rules.d/92-local-vchiq-permissions.rules

I don’t know if there is a “more proper” way of fixing that, or why it happened in the first place… (i think it worked directly on my fresh —i mean not upgraded— 15.10 install on an SD card.)

The change above is present in Ubuntu MATE 15.10 and 16.04 for the Raspberry Pi.

1 Like