Indicators are disabled in MATE Tweak

Both the Enable Indicators and the Enable Advanced Menu in Mate Tweak under the Interface tab are disabled and I can’t set them on. Why is that and how can I activate these options back on?

I’ve found they get disabled after I save my own panel layout. When you switch back to one of the default layouts then those options are re-enabled, but you lose your customizations.


@marfig please state which version of Ubuntu MATE you are using and when you got this error.

And are you logged in as “Guest” or normal user?. :smiley:

You are right, I’m sorry.

I’m using Ubuntu MATE 16.04 64-bit with the default MATE 1.12.1
This happens regardless of the window manager I choose, if that makes a difference. Currently on Marco (Software), because the other two create problems of one sort or another.

@wolfman, It’s the standard sudoer account that I set up during the Ubuntu MATE installation process.

All working fine here!, have you done a full system update?:

Thank you for that. I bookmarked the link and will get to it when I have a chance.

1 Like

I have noticed that as well.

1 Like

That happens to me too.

I think it’s intentional the option is greyed out.

Changing panel layouts (and toggling checkboxes) assume a stock “unmodified” panel and any change ends up replacing the existing layout for that stock panel with those desired options.

After saving a custom panel, it could have been radically customised that it’s no longer the “base panel” that was originally selected… so MATE Tweak doesn’t really know.

So instead, to properly disable/enable indicators, the panel needs replacing and that’ll destroy any customisation. :frowning: I believe toggling the option makes changes in the background (for example, so that the correct sound applet/indicator appears)

1 Like

I have no doubt this is the intended behavior. But IMHO this would be a good place to improve user feedback.
How about a tooltip that pops up and says “This option has been frozen in your customized panel layout” or something like that?


Excellent @lah7. That explains it. Thank you :slight_smile:

Like @ouroumov, I agree that user-feedback could improve here. But in any case, glad to know everything is working as intended.

I’ll pass on the suggestions to @Wimpy. :slight_smile: