Install Seamonkey

I had to reinstall UM from scratch. :frowning:

Trying to get Seamonkey to run.

When I run seamonkey or seamonkey-bin, I get

  failed to execute file seamonkey

When I try to add key

andy@7:~$ sudo apt-key adv --recv-keys --keyserver 2667CA5C
Executing: /tmp/apt-key-gpghome.DJhzD9np1u/ --recv-keys --keyserver 2667CA5C
gpg: keyserver receive failed: Connection timed out

You followed the 4 commands referenced here - ?

cat <<EOF | sudo tee /etc/apt/sources.list.d/mozilla.list
deb all main

sudo apt-key adv --recv-keys --keyserver 2667CA5C
sudo apt-get update
sudo apt-get install seamonkey-mozilla-build
1 Like

Or did you just download an appropriate *.deb from the ppa?

Yes, but I could not add my key.

So I could never do the last steps.

One great blessing is that for some reason, my scanner now works. :slight_smile:

When i try to download deb...

Hmm. We’re having trouble finding that site.

We can’t connect to the server at
If that address is correct, here are three other things you can try:

Try again later.
Check your network connection.
If you are connected but behind a firewall, check that Firefox has permission to access the Web.

I use Seamonkey for more than 10 years now and this was the first I did in my Ubuntu Mate.
Most important: You don't install Seamonkey but you simply run it.

What sounds complicated is in reality all about Download -> Extract the .tar.bz2 file to a folder in your Home directory -> run Seamonkey from the Panel linking to your extracted seamonkey folder.

Tip: With each Seamonkey update, I repeat the download process and create a new folder for the new version. But I'm a more organised person.
In fact, if you place the extracted seamoneky folder in your home directory and exchange that folder with each update, it's less work for you.
Your bookmarks and passwords are not affected by an update. They are stored in .mozilla/(which is a hidden folder in Home).

  1. Download Seamonkey 64-bit for Linux from here:
    Note: the download links in Downloads are for 32-bit, and can't be used.
    Therefore: Scroll down to "Contributed builds (other platforms)"
    In Linux/x86_64, click on Linux/x86_64 .tar.bz2

  2. test@ubuntu:~$ mkdir Programs
    Result: You now have a folder called "Programs" in your Home directory.

  3. test@ubuntu:~$ cd Programs
    Result: In Terminal, you operate now from inside the Programs folder.

  4. test@ubuntu:~/Programs$ mkdir seamonkey4
    Result: In Programs, you have now a folder called seamonkey4.
    Note: Reason why I called it seamonkey4 is that the current versionis 2.49.4. With each new release, I repeat this step and will then have seamonkey5 etc.

  5. Copy the downloaded .tar.bz2 file to seamonkey4 folder. Or download as described in step 1 to seamonkey4 folder.

  6. Open folder seamonkey4 in Caja and right-click on .tar.bz2 file -> Extract here
    Result: you have a folder "seamonkey", which is the program you can now run.


Because I don't want to open Seamonkey in Terminal, I added it to the Panel.

  1. Right-click on Panel and go to “+ Add to Panel”.

  2. Click on “Custom Application Launcher”.

  3. Fill out Name and Command of the program which is the location in the Program folder.
    The icon seamonkey.png can be found in /home/test/Programs/seamonkey[version]/seamonkey/ chrome/icons/default

  4. Finish by clicking on OK.

Tip: Because the Seamoney sliderbar is very small, I found this entry in Ubuntu Mate forum and added .config/gtk-3.0/gtk.css.

scrollbar slider { /* Size of the slider */ min-width: 15px; min-height: 15px; border-radius: 17px;

/* Padding around the slider */ border: 2px solid transparent; }


I hope it helps.

seamonkey installed fine here from this PPA Ubuntuzilla
your ppa could be messed up I would go to synaptic and remove it and reinstall it using the above ppa.
or download seamonkey directly

I did what you say and I still get

       failed to execute file seamonkey

I still get

   gpg: keyserver receive failed: Connection timed out

Is there another way to install the key?

You shouldn't have the same folder in name in both seamonkey folders.
Obviously, the "Seamonkey" folder (capital S) is the main folder in your Home directory. Now, in Seamonkey should be the extracted "seamonkey" folder containing the entire package (chrome folder, etc). If it isn't thecase, then extract to that first "seamonkey" folder (lower s).
Open "Seamonkey", and right-click on seamonkey -> Open in Terminal.
Then type ./seamonkey

Otherwise, if the current UM is a fresh installation, then install the entire system again and then do it as I described.

PS: Make sure that you really created the folder Seamonkey via Terminal, because it seems that you might have a permission issue, looking at

andy@7:~/seamonkey$ ./seamonkey
bash: ./seamonkey: No such file or directory

By the way, seamonkey is an executable, not a script.

Sorry, but doing a whole new installation seems pointless and wasteful of time.

When I run this command, then my Seamonkey launches.
If you are sure that

  • in your folder seamonkey the content of the extracted 64-bit is, and
  • the other folders before the program folder seamonkey were build as described also on the Seamonkey Project website with the correct permissions as admin, and
  • there is a file called seamonkey,

then the only conclusion is that your system isn’t working correctly.

I do this with Seamonkey in all systems and it works even in Gnome Fedora. I never had any issues with that.