Install VMware Tools in Ubuntu Mate 15.04

Can anyone help?

I am stuck solving a problem installing VMware Tools.

I have VMWare Fusion on my Mac (7.1.3). I successfully installed Ubuntu MATE 15.10 using ubuntu-mate-15.10-desktop-amd64.

I can’t get VMWare Tools to work as expected.

I can manually get it to work, by using the command /usr/bin/vmware-user
But when I restart the machine the tools are not working.

The Tools nstaller appears to run perfectly with no errors.

Can anyone point me in the right direction?

Regards,

Karl

hi Karl,

does this help?:

https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1022525

Hi there Wolfman
Thanks for the reply. I tried following that guide, making sure the prerequisites were definitely in place and still get problems as I described.
Maybe it is just a problem with MATE v 15.10?
It is interesting to note that version is not yet on the officially supporting Guest OS’s on the VMWare site.

Hi Karl,

it might just be a case of missing dependencies, try the following terminal (Ctrl + Alt + t) command and restart if anything updates:

sudo apt-get install -f

Hi Thanks again for the info and advice.
I will try that as soon as I get home and let you know the outcome.

Hi Wolfman
The update found nothing to update.
Do you have any other tips/suggestions I could try?

I believe I now understand the problem.
Inn VMWare Fusion if I go to System Settings > Display and untick Accelerate 3D Graphics then all is well.

1 Like

Great Karl,

please mark your own answer as best answer so it helps others!. :smiley:

To conclude this threat I would like to recommend this video I found.
It is the closest I could find to a VMWare Fusion tutorial and worked well for me, even allowed me to leave 3D acceleration ticked.
If like me, you have been struggling to get Ubuntu Mate 15.10 to play nicely the
take a look.
Here’s the link:

1 Like