Installing MATE desktop changed my firefox homepage -- how do I undo this?


#1

I installed MATE desktop on 18.10 and it changed my FF startpage to a search page with the MATE logo. How can I undo this?


#2

Same here and I've tried to change it back to my original home page under Firefox preferences but it won't save


#3

At first restore the permissions of Firefox's folders:

sudo chown -R $USER:$USER ~/.mozilla/firefox ~/.cache/mozilla/firefox

Then try again to set it from Firefox's Preferences: HomeNew Windows and Tabs:

  • Homepage and new windowsBlank page (or your personal choose)
  • New tabsBlank page (or your personal choose)

And only if manual settings does not survive after reboot, then remove corresponding files from terminal with

sudo rm /usr/lib/firefox/ubuntumate.cfg
sudo rm /usr/lib/firefox/defaults/pref/all-ubuntumate.js

You can always bring this behaviour back with

sudo apt-get install --reinstall ubuntu-mate-default-settings

Reference link: Ubuntu MATE always forces search start page in Firefox


#4

Uninstalling ubuntu-mate-default-settings did the trick. Thank you! I must say that is a fairly unfortunate choice made in that package -- a default being a hard-to-impossible-to-change change in the browser homepage.


#5

You should uninstall the whole ubuntu-mate-default-settings package, but simply remove two files instead.

Also note that I can't reproduce the issue on clean Ubuntu MATE 18.10 VM, I have changed settings inside Firefox and they were saved normally.