Just installed MATE. Worked great, lost ethernet (but not wifi) after sleep

I just installed the newest 16.04.4 LTS release of Ubuntu Mate. Everything was working great for maybe 30 minutes to an hour, until I put the computer to sleep. When I came back, I had lost all ability to connect to the internet via hardwire. The wifi works just great, and speed is excellent, but I’d like my wired connection back. I also have no 5g ability (just the basic N and G, I assume).

My computer is an HP Pavilion 17-e049wm with AMD A10-5750M CPU. Seems to be using the RTL8188EE chipset for wireless.

Any thoughts? Thank-you.

Hi @DerekF,

if you click on the network icon in the panel, what does "Edit connections" tell you?:


After Ethernet Connection 1 quit working, I deleted it and created Ethernet Connection 2. It’s there, works fine after a reboot, and until the computer goes to sleep. Once it wakes up, it no longer works. The icon just keeps spinning. Restart the computer and it works again, until it goes to sleep.

I don’t use sleep mode for the very reason you describe above, it seems to lock up parts of the system, if I walk away from my PC, I simply log out and log back in when needed, it doesn’t save any power but it is at least stable!.

I really don’t have any other suggestions for you as hibernation has caused problems in Ubuntu for a long time!. :smiley:

This is likely a driver issue according to the ubuntu help page. Unfortunately I suppose you cannot unplug or restart the Ethernet port by itself. I haven’t heard of Ethernet drivers so I assume that’s a kernel issue then?


You should not have to delete the connection but simply restart your pc

Sadly, this is what I’ve been doing. I will just shut it down entirely, when not in use. When it goes into sleep mode, it totally breaks something related to my hardwired ethernet. I’m fine through wifi, insofar as I can tell. I would just use wifi, but I’m at the far end of the house.

I have turned off sleep/hibernate entirely, other than just letting the screen go black. I set up a keyboard command to shut down easily.

I’ve also got a boot loader to fix, as HP doesn’t like giving control to something other than windows… having to get to Ubuntu manually. I am fine on a 2nd machine, which is all “intel inside.” AMD seems to not play so well (I had heard that).

Deleting and making a new connection doesn’t help it, anyway. Restarting is the only thing that brings it back, after broken within sleep.

Hi Derek,

I am running an AMD rig with one of their latest CPU’s (Athlon X4 950) and don’t have any problems with it!. :smiley:

Anyway, I really cannot say anything more than I said above. Either log out or shut down which is what I do. I am sure that there is a fix somewhere but I have heard of this problem for years and simply don’t bother about it!. :smiley: