Keyboard light keeps turning on after login and / or unlock

I have a Dell XPS 13 9343. Make sure you are changing the correct option. There are two different things that say KbdBacklight. I had to scroll to see the second option. I accidentally changed the first option when I did it the first time.

1 Like

Asus q400a same issue here

1 Like

Hello,

This sounds somewhat familiar to a problem that I have faced earlier this year when I purchased a Cooler Master keyboard + mouse Devastator combo.

The gimmic was that both the mouse and the keyboard had flashing lights dimming from/to all colors in the rainbow.

So I plugged the mouse in and it worked fine. But the keyboard had 0 light poping up on it yet it worked fine. After some mixed interactions with (I even claimed a RMA thinking it was defective), my girlfriend simply plugged it into a windoze 10 machine and THE LIGHTS WENT ON! Plugging it back however into a Linux host brought the same initial result: keyboard worked but not the lights.

At ths point I simply lost all hope of getting it working and reverted back to a “regular” keyboard.

This is probably not the answer you were looking for but, hey, true story nonetheless.

Cheers,

DLS

Let’s bring this VERY USEFUL Thread alive. :slight_smile:
I havent any Dell. Mine’s Asus Zenbook UX32VD.
That being said, the fix you proposed works for me, independently from what line I change from “allow” to “deny”. (Works with first as well as second line)
Problem: The Zenbook has no ON and OFF backlight switch. You can turn it off and on using Fn + LIght up or light down, until it is completely off, or completely on (Has 4 level OFF > LOW ON > MIDDLE ON > HIGH ON)
As i said, it works, but completely disable the possibility to turn the keyboard light on when it’s needed.
In the Zenbook, even when the screen dim down to save power, and then you dim up again moving the mouse, the keyboard light turn on again, even from OFF state.

Using Ubuntu Mate 16.04 with Mate 1.16.1 here.

1 Like

Works fine on Lenovo ThinkPad X230, can turn on keyboard light any time I wish. Thanks!!!

1 Like

fANTASTIC! This fix works beautifully for me.
My config:
Thinkpad X230 running ubuntu mate 16.04.2.

The keyboard backlight used to randomly keep turning itself on, changing the conf file as per your comment totally fixed this. Thanks @CrazyDesi

Loving ubuntu mate so far.

1 Like

This approach fix this problem in my Lenovo Thinkpad T450

This also works for my Lenovo Thinkpad T460

No approach mentioned in this post worked for me. I added my own here:
https://askubuntu.com/a/936007/712359

Note it doesn’t requiere root privileges. Hope it helps.

On Yoga 260 and Mint 18.2 this solution works partially:

  • if the keyboard is off, it will stay off, great!n?
  • BUT if the keyboard is on, it will turn off after a screen locking/closing lid action.

Any other solution that is able to keep the state of the keyboard after a screen locking actio

Ubuntu 17.10 & MATE Desktop 1.18.0

Ran into same issue of keyboard backlight always turning on after login.

My temporary workaround is simply to run the following as your normal user (no sudo):
gsettings set org.mate.power-manager kbd-brightness-on-ac 0

also, so that it doesn’t keep turning back on after coming back from idle when on battery:
gsettings set org.mate.power-manager kbd-backlight-battery-reduce false

3 Likes

Ubuntu Mate 18.04. Had the same issue on an Asus Zenbook UX330U. The above fix solved the problem.

…but now I can’t brighten or dim my keyboard at all, using fn + f3 (which normally dims the keyboard keys), nor fn + f4 (which normally brightens up the keyboard keys). I’m shining a flashlight on my keyboard to type right now. :frowning:

Note that Manjaro Gnome gets this right: fn + f3 and fn +f4 work as they should, and it always remembers the brightness level how you left it, and no fix/hack in /etc/dbus-1/system.d/org.freedesktop.UPower.conf was ever needed.

I am indebted to you not so CrazyDesi. On my laptop (Dell Inspiron convertible 15-5578) the keyboard backlight turning on after turning off was really getting to me and one thing that was p***ing me off with Linux Mint. Normally in the typing of this message; backlights would have turned on a couple of times; didn’t happen so thank you very much.

The org.freedesktop.UPower.conf workaround worked on my Dell XPS 9380 (with Mint 19.1 MATE, which is based on Ubuntu 18.04).

The issue I was suffering was that on logon, the keyboard backlight would turn on, even if it's disabled in the BIOS.

Somebody mentioned a fix in upower; as experiment, I've upgraded the upower packages (libupower-glib3 and upower) in my system to the Ubuntu 19.04 versions, however, they didn't solve the problem, so I expect this issue not to be fixed for a long time.

The fix mentioned in https://bugs.launchpad.net/dell-sputnik/+bug/1510344 (SystemD masking) didn't work.

Asus N501VW with 19.04

I use an external monitor with the laptop lid down so if the kb light is on it gets too hot in there.

I don't see a Upower configuration file. Perhaps it is not installed.

In desperation I am running :

echo '0' > /sys/devices/platform/asus-nb-wmi/leds/asus::kbd_backlight/brightness

as a root cron every five minutes!

Cripey!

The file is located at /usr/share/dbus-1/system.d/org.freedesktop.UPower.conf in 19.10.

1 Like

Problem solved!
I have edited the file, and restart the computer.

sudo pluma /usr/share/dbus-1/system.d/org.freedesktop.UPower.conf

Line <allow send_destination="org.freedesktop.UPower.KbdBacklight"

Change to <deny send_destination="org.freedesktop.UPower.KbdBacklight"

Line <allow send_destination="org.freedesktop.UPower"
send_interface="org.freedesktop.UPower.KbdBacklight"/>

Change to <deny send_destination="org.freedesktop.UPower"
send_interface="org.freedesktop.UPower.KbdBacklight"/>

PS
Lenovo ThinkPad T450
Release 19.10 (Eoan Ermine) 64-bit
Kernel Linux 5.3.0-26-generic x86_64
MATE 1.22.2

2 Likes

Thanks, the proposed solution worked for my Asus Q34UAK laptop, with:
$ uname -a
Linux Mint 4.4.0-70-generic #91-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux

Using the editor xed edited the file: /etc/dbus-1/system.d/org.freedesktop.UPower.con

In the second expression containing KbdBacklight
replaced 'allow' with 'deny'

The keyboard backlight is now always off

Thanks CrazyDesi

Thank You, it worked on:
Lenovo ThinkPad T440
Release 19.10 (Eoan Ermine) 64-bit
Kernel Linux 5.3.0-46-generic x86_64
MATE 1.22.2