Login loop 18.04.3 and 19.10

Built a new pc with MSI X570 Pro, Ryzan 3700X, RTX2060 Super, 16gb. After applying updates and rebooting I login, see the Welcome screen start to pop up then loop back to login. Looked at other topics related to login loop and solutions do not work.

Did you do anything other than updating?

Edit: Like, did you install additional drivers or maybe you tried encrypting your home directory?

No drivers installed, same issue on 19.10. If I install without Third Party Drives the problem does not occur, however I can not load any Nvidia drivers.

Ok, so it works if you have Nouveau drivers, but not the NVIDIA drivers from Additional Drivers?

That is really weird...

If you have nothing else to try, then maybe try installing v440 of NVIDIA drivers directly from NVIDIA website (look up a guide if you don't know how). Ubuntu doesn't have v440 on the repositories yet.

Although I kind of doubt that your problem has to do with drivers...

I re-installed this morning without selecting third party software, after login in I get the Welcome screen asking if I would like to send information. I believe this is the screen which is trying to display when I am forced back to the login screen with an install selecting third party software.

I will try to load nvidia 440.

I have three monitor and before loading the nvidia drive all three worked and under displays they were detected. After installing nvidia-driver-v440 open source, only one monitor is working and the display is not detected, and can not change resolution.

Also when I load v440 I received a System error after it completes successfully. I will reinstall "again" and try the .run method.

Wait, what do you mean open source nvidia drivers? nvidia doesn't have open source drivers.

I entered the following:
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update

Opened additional drivers and there was a line for nvidia-driver-v440 open source along with 435 and 430.

Oh, I think it's just a bug that it is displaying open source; the driver is proprietary.

I don't think you need to try another method to install the driver. I'm not sure what is going on...

I'm assuming they are all connected via DisplayPort? And the one monitor that works is always on the same port I'm assuming?

But I don't understand what you mean by the display is not detected. When you go to the "Displays" options, there are no monitors showing at all? Also, while you are there, make sure "Same image in all monitors" is unchecked.

Edit: Also maybe see if there is an option in Nvidia X Server settings about monitors. I never tried connecting dual monitors to a desktop.

Edit 2: Try plugging in monitors after booting.
Also, If you get system errors on next boot type sudo dmesg in terminal and paste output here.

attached is the dmesg,

[    3.728951] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[    3.737770] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[    3.769672] cryptd: max_cpu_qlen set to 1000
[    3.772585] Intel(R) Wireless WiFi driver for Linux
[    3.772586] Copyright(c) 2003- 2015 Intel Corporation
[    3.772669] iwlwifi 0000:29:00.0: enabling device (0000 -> 0002)
[    3.775254] AVX2 version of gcm_enc/dec engaged.
[    3.775254] AES CTR mode by8 optimization enabled
[    3.798223] snd_hda_intel 0000:2d:00.1: Disabling MSI
[    3.798231] snd_hda_intel 0000:2d:00.1: Handle vga_switcheroo audio client
[    3.798298] snd_hda_intel 0000:2f:00.4: enabling device (0000 -> 0002)
[    3.818106] iwlwifi 0000:29:00.0: loaded firmware version 43.95eb4e97.0 op_mode iwlmvm
[    3.836964] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC1220: line_outs=3 (0x14/0x15/0x16/0x0/0x0) type:line
[    3.836966] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    3.836966] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    3.836967] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[    3.836967] snd_hda_codec_realtek hdaudioC1D0:    dig-out=0x1e/0x0
[    3.836968] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[    3.836968] snd_hda_codec_realtek hdaudioC1D0:      Front Mic=0x19
[    3.836969] snd_hda_codec_realtek hdaudioC1D0:      Rear Mic=0x18
[    3.836970] snd_hda_codec_realtek hdaudioC1D0:      Line=0x1a
[    3.838286] iwlwifi 0000:29:00.0: Detected Intel(R) Dual Band Wireless AC 9260, REV=0x324
[    3.850189] input: HD-Audio Generic Front Mic as /devices/pci0000:00/0000:00:08.1/0000:2f:00.4/sound/card1/input16
[    3.850213] input: HD-Audio Generic Rear Mic as /devices/pci0000:00/0000:00:08.1/0000:2f:00.4/sound/card1/input17
[    3.850234] input: HD-Audio Generic Line as /devices/pci0000:00/0000:00:08.1/0000:2f:00.4/sound/card1/input18
[    3.850254] input: HD-Audio Generic Line Out Front as /devices/pci0000:00/0000:00:08.1/0000:2f:00.4/sound/card1/input19
[    3.850274] input: HD-Audio Generic Line Out Surround as /devices/pci0000:00/0000:00:08.1/0000:2f:00.4/sound/card1/input20
[    3.850293] input: HD-Audio Generic Line Out CLFE as /devices/pci0000:00/0000:00:08.1/0000:2f:00.4/sound/card1/input21
[    3.850312] input: HD-Audio Generic Front Headphone as /devices/pci0000:00/0000:00:08.1/0000:2f:00.4/sound/card1/input22
[    3.885199] iwlwifi 0000:29:00.0: base HW address: 18:56:80:17:79:f6
[    3.915837] kvm: disabled by bios
[    4.028850] MCE: In-kernel MCE decoding enabled.
[    4.028885] kvm: disabled by bios
[    4.030012] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    4.030195] thermal thermal_zone0: failed to read out thermal zone (-61)
[    4.076505] iwlwifi 0000:29:00.0 wlp41s0: renamed from wlan0
[    4.128660] kvm: disabled by bios
[    4.153222] audit: type=1400 audit(1572979088.830:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-oopslash" pid=972 comm="apparmor_parser"
[    4.153453] audit: type=1400 audit(1572979088.830:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-xpdfimport" pid=975 comm="apparmor_parser"
[    4.153526] audit: type=1400 audit(1572979088.830:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/man" pid=971 comm="apparmor_parser"
[    4.153527] audit: type=1400 audit(1572979088.830:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_filter" pid=971 comm="apparmor_parser"
[    4.153528] audit: type=1400 audit(1572979088.830:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_groff" pid=971 comm="apparmor_parser"
[    4.153598] audit: type=1400 audit(1572979088.830:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/ippusbxd" pid=979 comm="apparmor_parser"
[    4.153746] audit: type=1400 audit(1572979088.830:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-senddoc" pid=973 comm="apparmor_parser"
[    4.153924] audit: type=1400 audit(1572979088.830:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cups-browsed" pid=977 comm="apparmor_parser"
[    4.154074] audit: type=1400 audit(1572979088.830:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=969 comm="apparmor_parser"
[    4.268798] kvm: disabled by bios
[    4.404675] kvm: disabled by bios
[    4.520887] kvm: disabled by bios
[    4.660878] kvm: disabled by bios
[    4.744649] Generic PHY r8169-2700:00: attached PHY driver [Generic PHY] (mii_bus:phy_addr=r8169-2700:00, irq=IGNORE)
[    4.780884] kvm: disabled by bios
[    4.782160] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.1/0000:2d:00.1/sound/card0/input23
[    4.782233] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.1/0000:2d:00.1/sound/card0/input24
[    4.782293] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.1/0000:2d:00.1/sound/card0/input25
[    4.782340] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:03.1/0000:2d:00.1/sound/card0/input26
[    4.858991] r8169 0000:27:00.0 enp39s0: Link is Down
[    4.884987] kvm: disabled by bios
[    5.009024] kvm: disabled by bios
[    5.144983] kvm: disabled by bios
[    5.256883] kvm: disabled by bios
[    5.380964] kvm: disabled by bios
[    5.473048] kvm: disabled by bios
[    5.628884] kvm: disabled by bios
[    5.776989] kvm: disabled by bios
[    8.424177] wlp41s0: authenticate with 44:1c:12:ed:90:1f
[    8.426349] wlp41s0: send auth to 44:1c:12:ed:90:1f (try 1/3)
[    8.464972] wlp41s0: authenticated
[    8.468046] wlp41s0: associate with 44:1c:12:ed:90:1f (try 1/3)
[    8.473445] wlp41s0: RX AssocResp from 44:1c:12:ed:90:1f (capab=0x1511 status=0 aid=8)
[    8.474321] wlp41s0: associated
[    8.504614] IPv6: ADDRCONF(NETDEV_CHANGE): wlp41s0: link becomes ready
[    8.545258] wlp41s0: Limiting TX power to 127 (127 - 0) dBm as advertised by 44:1c:12:ed:90:1f
[   17.948130] systemd-journald[520]: File /var/log/journal/e97488c9943040768d320b099af8a5d2/user-1000.journal corrupted or uncleanly shut down, renaming and replacing.

That is not the full output.
Type in sudo dmesg >> output.txt, then copy from there.

Did you try checking Nvidia X Server settings?

Just for your information:
That commands basically says run dmesg as super user and write the output to output.txt (it will be in pwd since no full path is specified)

Usually, if you want to make sure that you have full output, you type sudo dmesg | less, which puts the output of dmesg into a command-line text viewer, called "less" (press q to quit and arrow keys to scroll), but it is kind of difficult to copy and paste from it.

1 Like

In order to get the dmesg info I have to cntl-alt-F3 to terminal then try to copy off. Sometimes I see my usb but when it does't I have to try and mount. And it just occurred to me the motherboard has an HDMI Processor with integrated graphics. Maybe that is the source of the problem when mixed with my RTX2060??

I checked the BIOS setting and the internal graphics is set to PEG. Also set for CSM-legacy.

Sorry. Don't know what is happening... Maybe someone else can help.
Is this Ubuntu Mate specific glitch?
If it happens on other Ubuntu flavors then maybe post on the normal Ubuntu forums. There are more people there usually, and someone more knowledgable might help.

I believe I found the problem, I replaced my boot SSD drive which I've had since 2016, created a fresh USB live boot. I did not select to download updates or third-party drivers. I ran for about six hours without an update, then applied updates and ran the rest of the day without issue.

This morning I loaded the nvidia drivers:
$ sudo add-apt-repository ppa:graphics-drivers/ppa
$ sudo apt-get update
$ sudo apt install nvidia-driver-430

rebooted, was able to run nvidia.smi and the GUI app.

Moving on, thanks for being willing to help.

So the problem was the storage?

It was a stab in the dark, I remember I had on a Windows 7 machine doing strand things. Went through the process then of swapping memory, video card, motherboard and finally the hard drive. The HD was the issue so why not a flaky old SSD.