Login screen not working

Hi folks,

After upgrading to Ubuntu 17.10, everything worked fine. However, today I was no longer able to log in via the login screen. Confirming the password entry by pressing ENTER, I get a message saying that the password is not correct or I get an empty password field again, respectively. Nothing else happens.

I can, however, log in using the command line mode and start the Mate desktop there using startx. Once the desktop has started, desktop session GUIit will accept my password for authehticating any kind of root action.

I’d appreciate any suggestion, what may have happened.

Welcome to the forum @peerwal. I used to get the same symptoms periodically in Ubuntu 14.04, but a reboot would clear the issue and login would work normally again. I’m assuming a reboot did not correct your login issue since you went to the trouble of logging in from the command line.

I see your password is accepted after you login from the command line. Still I wounder what might happen if you reset your password? You can do so from the command line, or from recovery mode.

How to reset your password from recovery mode:

  1. Reboot your computer.
  2. Hold Shift during boot to start GRUB menu.
  3. Press Esc at the GRUB menu and choose Advanced options.
  4. Choose recovery mode.
  5. Choose root.
  6. Type in passwd username
  7. Set your password.
  8. Reboot and see if you can login normally.


Replace username with the name of the user account you wish to change the password for.

You only need to hold the Shift key if the GRUB menu does not normally appear when you boot your computer.

If this doesn’t help, it might indicate something has become corrupted.

I can't help but think it's related to keyboard. It's as if the key mapping is different on the login screen known as lightdm, dm or slick-greeter depending where you look.

There's some icons in the upper right for assistive technology and a display indicating your keyboard setting. Here's what my US keyboard looks like.

The person in the circle is assistive technology and has an Onscreen keyboard. Does it work for your password? Does it look like your keyboard layout?

What I'm not sure of is how and where these are ultimately determined.

Plus, it could be related to certain characters mismapping in the login screen but nowhere else. I went looking for a way to display plain text of what's typed... gee... can't find one!

Thanks both of you, steven and Bill_MI, for the information you gave. I reset the password but this did not change anything. Also, once I started the Mate session from the command line, entering the password works fine e.g. if I want to edit the package sources.

The onscreen keybord has the same character mapping as my real keayboard (the top line of the login screeen says de and de_DE) and it does not work for my password either.

What I forgot to mention is that the GUI being started from the command line comes up with an error message saying that a system application has failed (my translation from German). Looking at the details there is an indication that there seems to have been a xorg crash.

Obviously, steven was right assuming that something has become corrupted.

I also noticed, that after a few attemps of entering the password in the login screen, the login button of the login box stops reacting to mouse clicks and pressing ENTER just clears the password field.

Indeed, corruption is indicated as @steven mentioned .

I believe the two main packages associated with this would be slick-greeter and lightdm. Both have dependents which have dependents and any one of these can be the culprit.

Short of a new install I’m not sure a reinstall of packages would help or hurt.

On the other hand, a good filesystem check (fsck) might find something. I suggest doing it from a live boot instead of forcing at boot - it can be made much more thorough.

Hi peerwal,

have you tried changing your software sources download location and updating again?:

Hi wolfman,

yes, I did so and I also re-installed slick-greeter and lightdm but none of these measures fixed the issue.

Maybe I just got to wait for the next system update to come hoping this will include a fix.

Hi peerwal,

try the following terminal command (Ctrl + Alt + t) which should install any missing dependencies:

sudo apt-get update && sudo apt-get dist-upgrade -f

Hi wolfman,

I already tried this command a couple of days ago but it did not change the situation.

Thanks very much, anyway.

1 Like

I googled lightdm not accepting password which returned several hits to forum post simular to yours.

1 Like


thanks to all of you for your support. However, I still can’t log in using lightdm, although I tried quite a few solutions given in different threads or posts I found when I googled the issue (most of which, however, were related to older versions of UM that e.g. were still using lightdm.cfg, which is no longer available in the actual version), such as:

  • I checked the ownership of .Xauthority and .ICEauthority
  • I re-installed/re-configured both lightdm and slick-greeter
  • I removed .Xauthority and .ICEauthority before trying
    to log in again.
  • Also created a new user but had the same problem.

None of the above measures fixed the issue and the only workaround I found was installing gdm3, which works fine mfor logging in.

So the issue is note yet solved but at least I got 2 workarounds, logging in via the command line or using gdm3.

HI peerwal,

try the following terminal commands as something may be broken?.

sudo apt --fix-missing install

The above command downloads and installs any missing packages on your system.

sudo apt --fix-broken install

The above command downloads and installs any broken dependencies on your system.

Surprising turn:
I purged gdm3 and installed/reconfigured lightdm again and now the login works here perfectly, too.

Issue solved.