MATE 20.04 - NVIDIA - Partial disregard of xorg.conf on boot

Hi all
I used NVIDIA X Server Setting to set my monitor parameters as follow;
"metamodes" "HDMI-0: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On, AllowGSYNC=Off}, DP-0: 2560x1440_144 +1920+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"

When I boot my PC it's not using ForceCompositionPipeline=On and ForceFullCompositionPipeline=On for my HDMI-0 monitor but it does on my DP-0 monitor.

so I have tearing on the HMDI-0 monitor, in the VIDIA X Server Setting those parameter are off, if I open xorg.conf everything is ok the file has not been modified.

Also if I untick Allow Flipping, after a boot it is back on.

Is there a flag somewhere to force the drivers to use the defined parameter or is this a bug ??

Thanks for your help

Blockquote

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 440.100

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section "InputDevice"

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier     "Monitor0"
VendorName     "Acer"
ModelName      "Acer R240HY"
HorizSync       31.0 - 75.0
VertRefresh     56.0 - 75.0
Option         "DPMS"

EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 1050 Ti"
Option "Coolbits" "4"
EndSection

Section "Screen"

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "Coolbits" "12"
Option         "Stereo" "0"
Option         "nvidiaXineramaInfoOrder" "DFP-2"
Option         "metamodes" "HDMI-0: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On, AllowGSYNC=Off}, DP-0: 2560x1440_144 +1920+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24
EndSubSection

EndSection

Blockquote