MATE Desktop 1.16 for Ubuntu MATE 16.04

Hi @Wimpy,

can I safely install this on UM 16.10 or is it already included?. :smiley:

Hi @wolfman, it’s definitely for 16.04 Xenial only. In fact, there’s no Yakkety in the PPA so there’s nothing offered if someone did try it by mistake. Safeguards are nicely in place for this sort of thing.

I just tried to be sure. VMs are so handy! :slight_smile:

1 Like

As @Bill_MI says, it’s absolutely not compatible with Yakkety. Also Yakkety comes with MATE 1.16.

1 Like

Thanks chaps. I looked at UM 16.10 and as you said @Wimpy, 1.16 is already installed, I installed it on my mini notebook running UM 16.04 which didn’t blow up so I assume it works!. :thumbsup:


Just did the upgrade. Worked OK. Except 1 package did not upgrade tts-mscorefonts-installer.
From the message it seems it could not find or download the package to upgrade.

Please advise how to rectify this.


See -

1 Like

I did the Mate 1.16 upgrade this morning, and all went well.

The TTF-MS fonts issue is a problem even in 1.14. It seems to be a problem with Sourceforge. I need those fonts for a couple of wine based programs I run.

I keep a copy of MS Fonts I copied from a windows install I had on this laptop when I bought it. The easiest method for me has been to open caja from a terminal with sudo caja and copy them into /usr/share/fonts/truetype/

Then I update my font cash with fc-cache -f -v or reboot.

BTW thanks Wimpy for porting 1.16 to 16.04. I tried 16.10 and while I have plenty of system resources to run it, but it was a little glichie for my taste, so I went back to 16.04. This is still the best Distro I have used so far on a laptop. Have it installed on everyone’s laptops in the house. It just runs, is low maintenance, and is a fantastic tool for getting the job done with enough room to customize it to taste.

If you’ve already tried to install the MS Fonts and gotten the download error, you can install them by running the following commands:

sudo dpkg -i ttf-mscorefonts-installer_3.6_all.deb

If you haven’t already tried to install the MS fonts, I think the above will fail due to a missing dependency.

It’s a known bug that’s reported in Launchpad. The main bug report, that I don’t think mentions the MS Fonts, is here.

If you’ve already installed the MS fonts that way, installing Mate 1.16 goes flawlessly.

Thank you for this LTS love!

Following this upgrade procedure had me panicking for a few minutes. After running the 3 commands I rebootet my Thinkpad and stared at a blinking text cursor instead of my login screen. First I thought, well, maybe some initialization is taking place, leave it alone. But after a while I decided this could not be the case. I forced power off, booted into recovery mode, then resumed normal mode from there and all was fine. Another reboot, this time without detour, worked fine. This is where I am now. Just to let everyone know.

Looks like the 1.16 PPA is down

Error reading Service Temporarily Unavailable

Its back up.

1 Like

The upgrade was flawless on Ubuntu MATE 16.04. I’m happy to see that the power manager brightness bug is also fixed. Thanks.

Hi Guys, to a friend I have to remove Ubuntu 14.04 and install Ubuntu Mate 16.04, I have ISO image 16.04, I think it has the Mate desktop 1.12,

After updating the system, can I install the Mate 1.16 desktop without installing on the 1.14 desktop?


On my computer 1.16 desktop goes great, thank you …

Hi @Josele13, I’ve done both successfully with this PPA on different 16.04 LTS installs:

Mate 1.12 -> 1.16 (by newly adding this PPA)
Mate 1.14 -> 1.16 (was already using this PPA from this older announcement)

A 16.04 install with Mate 1.14 likely already has this PPA and will be showing about 89 updates to get to Mate 1.16.

And yes, the 16.04 ISO is at Mate 1.12. Is this making sense?

But one of your questions is puzzling. Do you wish to stay at Mate 1.14? That isn’t as easy as the same PPA that got to Mate 1.14 has made the change to 1.16.

Hi Bill_MI, thanks for the clarification, my final confirmation is from my computer, I had desktop 1.14 and I upgraded to desktop 1.16, the question was about a new installation that I am going to make to a friend. regards…

This is what I did yesterday; I installed UM 16.04.1, upgraded the system, rebooted and then installed mate 1.16. It was flawless.

1 Like

I also noticed that the Thunderbird icon in the dock applet now shows an overlay indicating the number of unread mails.
Is this new with 1.16 or has this been there all along and I somehow always missed it?

I followed the suggested commands for my U-MATE 16.04 PPC edition, I saw the terminal or apt installing “MATE 1.16” items but, on reboot the MATE session was gone–the log in for an old GNOME DE was “default” but nothing to log into. So I logged into XFCE and then I tried running “apt-get dist-upgrade” and same issue after installing a number of other packages not installed by apt. Then I ran “sudo apt-get -f install” and that showed a few other packages to install . . . then I shut the computer down . . . on reboot, same problem . . . MATE is “gone” in PPC land . . . . Only “problem” I recall is there was something about “keyring not found”??? but, it continued on with the “full-upgrade” . . . that end happened a little too fast to know if that was an “issue.” It ran through the 200MB full upgrade process, and the cursor “returned” w/o reporting any other errors–that was a couple hours ago–I saw in the thread here that wimpy said the “ppa was down” . . . not sure if I ran my process then or well after . . . ??

A little surprising in that generally the U-MATE upgrades have been pretty smooth–don’t know if this is part of the “PPC is persona non grata” problem??

Any thoughts, happy to try them out . . . .


Another, unfortunately less pleasant observation about the dock:

The pop-up looks a bit off (and that's with pretty much every theme).

I’ve done at least 3 fresh system installs the last couple of days. To be honest I don’t remember what triggered that. The first time around I installed Ubuntu Gnome because I have been needing some desktop connectivity to my Google account. Contrary to the latest claims about Gnomes Google connectivity it really doesn’t work very well. On top of that you are still dealing with their poor excuse of a file manager Nautilus.

Round 2 I installed Ubuntu Mate 16.10 but there were graphics issues that were just annoying me and no way to get them to correct themselves. My laptop has Intel i7, 12gb ram, and nvidia m-840 graphics. open source or proprietary graphics drivers made no difference, neither did the compositor being used. So I decided to reinstall 16.04.1 which is back to running fine after upgrading Mate to 1.16.1 installing proprietary drivers and running a full- upgrade.

I’m going to sit back and see how things transpire for awhile with the current LTR. At the end of the day when I have to start spending more than a normal amount of time messing with the system to correct issues to make it run properly I will go back to running Debian Testing non-free. That generally takes a couple of hours to install and set up, but after that is tends to be a no hassle system that semi rolls and provides a good couple of years service until I mess around with it and need to re-install.