Mate doesn't activate on startup

Hi all,
I had regular Ubuntu 18.04 system, as it upgrades from 16.04. I wanted to customize it with mate as a display manager. I had done that a couple years ago without a problem. This time mate doesn't activate on startup. The logo comes on, disappears after half a minute and I get the Ubuntu desktop that I had before and wanted to replace. What could I have done wrong, or failed to do right?

Hi ffrr,

at the login window, click on the cogwheel icon (where you enter your PW) and make sure you have selected Ubuntu Mate as the default desktop!. :grinning:

1 Like

Hi Wolfman,
thanks for your remark. Problem is, I don't get a login window. I get a mate logo parading dots left to right for a while, then all but disappears and in the top left corner it says "Ubuntu desktop" and that's the way it looks, nothing like mate.
Frederic (ffrr)

Hi @ffrr :slight_smile:
Do you have enabled auto login on your session ? (without password)

You can disable it here :
image

and fallow @wolfman tip.

You can also run sudo dpkg-reconfigure lightdm
and select mate as default manager.

sudo dpkg-reconfigure lightdm produces a two-item menu: gdm3 and lightdm. 'lightdm' is selected, so I don't need to do anything but hit 'enter' and nothing changes. Surely something must have gone wrong with the download.Here is what I did:

To begin with I have a working 18.04 LTS installation, which I made upgrading 16.04 LTS . I remember opting out of boot requiring password. Next I wanted to change the desktop to mate.

$ sudo apt-get install mate (I have the entire stdout of the operation in a file (752 lines))

This didn't change the desktop. So I googled and found a step-by-step guide on:
https://linuxconfig.org/how-to-install-mate-desktop-on-ubuntu-18-04-bionic-beaver-linux

Following the guide I did:

$ sudo apt-get install tasksel
$ sudo apt update
$ sudo tasksel install ubuntu-mate-desktop
xserver-xorg install

I restart. The mate logo with the parading dots show for half a minute, after which I suppose I should see what the guide shows: a green page with a kind of triangular tiling and the login prompt next to the mate logo. This page I don't see. Instead I see the red page of the upgrade, application icons at the left hand border and no workspaces (e.g. 3 by 2; Ctrl-Alt-Arrow).

I would undo the dysfunctional stuff, if I knew what it is. And I would redo right what I must have done wrong, if I knew what that is. I downloaded an Ubuntu-mate-18.04.4-desktop-amd64.iso. I suppose with that I could start from scratch. I'd much prefer a less radical method, though, if there is one.

Frederic

Can you check what you have here as config ?

┌─[✗]─[[email protected]_apbook04u]─[]
└──╼ $cat /usr/share/lightdm/lightdm.conf.d/
50-disable-guest.conf       50-slick-greeter.conf
50-disable-log-backup.conf  50-ubuntu-mate.conf
50-greeter-wrapper.conf     50-xserver-command.conf
50-guest-wrapper.conf       90-nvidia.conf
┌─[✗]─[[email protected]_apbook04u]─[/usr/share/applications]
└──╼ $cat /usr/share/lightdm/lightdm.conf.d/50-ubuntu-mate.conf 
[Seat:*]
user-session=mate

Maybe you have to remove (better rename to .conf.old) the file that loads the ubuntu gnome desktop.

Here are the files i find in /usr/share/lightdm/lightdm.conf.d:

[email protected]:~$ ll /usr/share/lightdm/lightdm.conf.d
total 52
drwxr-xr-x 2 root root 4096 Jun 27 09:35 ./
drwxr-xr-x 4 root root 4096 Aug 1 2017 ../
-rw-r--r-- 1 root root 152 Mär 22 2018 50-disable-guest.conf
-rw-r--r-- 1 root root 76 Mär 22 2018 50-disable-log-backup.conf
-rw-r--r-- 1 root root 66 Mär 22 2018 50-greeter-wrapper.conf
-rw-r--r-- 1 root root 62 Mär 22 2018 50-guest-wrapper.conf
-rw-r--r-- 1 root root 39 Feb 17 2018 50-slick-greeter.conf
-rw-r--r-- 1 root root 29 Mai 2 2018 50-ubuntu.conf
-rw-r--r-- 1 root root 27 Aug 17 2017 50-ubuntu-mate.conf
-rw-r--r-- 1 root root 28 Mai 2 2018 50-unity.conf
-rw-r--r-- 1 root root 39 Mär 14 2018 50-unity-greeter.conf
-rw-r--r-- 1 root root 45 Mär 22 2018 50-xserver-command.conf
-rw-r--r-- 1 root root 164 Aug 27 2018 90-nvidia.conf

And this what I did:

[email protected]:~$ sudo mv -v /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf.-
[sudo] password for fr:
renamed '/usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf' -> '/usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf.-'

Restart

No change! Perhaps I should neutralize some of the other files.

1 Like

And what is inside this file ?

[email protected]:~$ cat /usr/share/lightdm/lightdm.conf.d/50-ubuntu-mate.conf
[Seat:*]
user-session=mate

Hi Frederic,

log out and look at the cogwheel again, if you had Ubuntu as a base before Mate, it will most likely be the default, if you click on the cogwheel, there should be a menu with at lease 2 - 3 - 4 options!. :grinning:

Make sure you also install the following if manually installing Ubuntu Mate:

sudo apt-get install mate-desktop-environment-core mate-desktop-environment-extras

Wolfman, thank you for the tip. I ran the command and restarted. Nothing has changed. The only cogwheel I see is in the upper right hand corner of the screen when the boot finishes. I believe the cogwheel you refer to is the one in the password template. That template never appears. Is that so because I opted out of password-protected login when I upgraded to 18.04? If so, how could I opt in now? Another thought I had was that my installation of mate occurred in two attempts: the first was "apt-get install mate", and when that install wasn't successful I ran "sudo tasksel install ubuntu-mate-desktop". That got me into the current situation (unchanged Ubuntu Desktop). Now, the question is, should I have done "apt-get remove mate" before starting the second install of "ubuntu-mate-desktop". My gut feeling suggests that installing and removing stuff out of sequence is not the best way to preserve coherence. I am tempted to "remove mate" now, but system maintenance had better not be done by trial and error.

Hi :slight_smile:

You dont have this login screen with this little white circle ?

image

Please logout and try clicking it to see if mate is listed.

1 Like

No, I don't have this login screen. I suppose because at upgrading time I opted out of password-login. I guess I should activate password-login and restart. Offhand I don't exactly know how to opt in. I tried something else: "remove mate" in simulation mode, just to see what it would do:

Terminal >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
[email protected]:/media/fr/5E30A37730A354B5/E6500/home/fr$ sudo apt-get -s remove mate
[sudo] password for fr:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'mate-desktop-environment' instead of 'mate'
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Terminal End <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

"mate-mate-desktop" is installed and checks out. Double-checking:

Terminal >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
[email protected]:~/logs/install/openpyxl$ dpkg -s ubuntu-mate-desktop
Package: ubuntu-mate-desktop
Status: install ok installed
Priority: optional
Section: metapackages
Installed-Size: 20
Maintainer: Ubuntu Developers [email protected]
Architecture: amd64
Source: ubuntu-mate-meta
Version: 1.225
Depends: alsa-base, alsa-utils, anacron . . . etc.( 75 names)
Recommends: a11y-profile-manager-indicator, acpi-support . . . etc. (183 names)
Description: Ubuntu MATE - full desktop
This package is the complete Ubuntu MATE desktop environment.
.
It is safe to remove this package if some of these packages are not desired.
Homepage: https://launchpad.net/ubuntu-mate/
Terminal End <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

Could it perhaps be that the order of lines in "/usr/share/lightdm/lightdm.conf.d" matters, if it is read top down until the first hit. Or should among multiple valid lines all but the applicable one be commented out?

Wolfman, Olek,

We did it! It works! This morning I start up and what do I see? A Mate desktop! I don't know why, but so what. I guess my investigative excursion of yesterday through the "apt" ecosystem somehow ironed out one or the other wrinkle. Be this as it may, your suggestions have been most helpful in directing my investigations. I thank you both!

Frederic

2 Likes

Nice :wink:

I hope you will enjoy the mate desktop :slight_smile:

Congrats :slight_smile:

1 Like