MATE on Wayland!

So I saw a snap in the snap store for MATE on Wayland put out by the person who is doing a lot of work on MATE and Wayland, experimental of course. So I installed it out of curiosity, however it just looped when trying to login on Wayland, however when I started my computer today, and logged in as normal a window popped up about Mir on X, and I knew that MATE was using Mir for at least one of their Wayland compositors, so I logged out and tried the Wayland session, this time it worked :smile: so Istarted messing around, most of the panel applets did not load, most of my applications did not work including caja, however Evolution and most MATE apps not tied to caja did, but I WAS RUNNING MATE on WAYLAND. It was themed in horrible Adwaita, and I could not get logged out, so I finally bought up the Run application, one of the few that actually work, and ran shutdown now -r, which worked, although it is far from perfect I'm very excited to actually be able to run MATE on Wayland. I wouldn't try this unless you like to experiment, because I messed my custom panel configuration entirely up, however thankfully I had it saved in mate tweak and restored it, so it turned out fine and was great fun experimenting with it.

MATE almost feels quicker on Wayland/Mir than it does on X


There's been an update to the snap That addresses some of the issues you saw:


Thanks for testing! As alan_g said, the snap has had a bunch of improvements in the last few weeks. These can be retrieved with a sudo snap refresh.

  • Caja is still a ways out on account of its heavy reliance on X11. We'll get Caja running eventually, but If you want a Wayland-compatible file manager in the mean time I suggest Nautilus or Nemo.
  • I'm not sure about the issue with theming. My guess is it's due to running in a snap, and unrelated to Wayland support
  • I fixed at least one bug that was messing up panel configurations. I'm sorry for any inconvenience that caused. Please @ me if panel configs are still getting corrupted.

As far as caja goes I'm just testing it out, not using it so I don't really care, theming may be a snap thing, panel configuration was fine as I had it saved in mate tweak when I went back to x11, I was just really excited to see it working, thank you for all the work you have done towards making it functional, besides gnome and kde, we are, the only de that even runs on wayland, excepting maybe enlightenment, and that's technically a wm, nobody can say that MATE is not caught up with other de s, when we are ahead of over half of linux de s, :grin:

Nice to see some progress on MATE on Wayland!


That's awesome and I was going to mention that firefox works on wayland in mate now, I don't remember it working in the previous test, also vlc works and plays sound and video perfectly, though it is themed weirdly compared to the rest off the desktop, and uses its own file chooser dialog, however I think a lot of things are still dependent on the full porting of caja, though there may be some work on it that's not in the snap yet's the progress with MATE Wayland?


  • We added Wayland support for Atril, System Monitor, Pluma, Terminal and other components of the Desktop. Furthermore Calculator and Terminal can now be built with Meson.

Work in progress...


So does MATE on Wayland will look like GNOME more?
Will this be in 21.10?

I'm sure @Utsuro would be happy that I'm stealing his thunder right now... :wink:

This means that many MATE applications work on Wayland now (I can verify that's true since I've been using Pluma and several others on Wayland for some time now). That does not mean that they all work on Wyalnd, nor does that mean they always work or work stably. For example, the MATE Panel is technically ported over to Wayland, so you can run that on Wayland now; however, good luck adding any "out-of-process" applets to the panel (that basically means good luck adding any applets, period, unless you build the panel from source code yourself)!

(Many panel applets do not work right now since out-of-process applets rely on a technology called XEmbed, which does not work on Wayland.)

I don't have the time right now to do a boatload of research on the subject, however I get the impression that MATE 1.26 is not going to make it into Ubuntu MATE 21.10; since the MATE Project was so slow to release 1.26, I can't see the Ubuntu MATE team QA-testing and then incorporating a new MATE release into an Ubuntu MATE release that'll be out in about two months. (But I am QA-testing MATE 1.26 anyway, don't worry!)

1 Like

That's inconvenient, means GtkSocket/GtkPlug method does not work in Wayland. Maybe dynamic loading would be an alternative. Like dlopen the plugin and let it return a widget.
I fouind a simple example. GitHub - fd3kyt/dlopen_example: An example of dlopen().

I've been experimenting once again with MATE components on Mir. Things have improved a bit since last time, but I found a weird thing:

Several of the components (mate-panel and mate-terminal for two) are setting DISPLAY=wayland-0 which is nonsensical and breaks any attempt to launch X11 based applications. Any suggestions where to look to correct this?