Mate Panel and Dual displays

Hi Ubuntu Mate community.

I’ve been stuck with a little annoyance and was wandering if anyone could help.
I have a dual screen display setup, one is 1920x1080 and the other is 1680x1050.
When i start up my computer, the top panel is sometimes on the one screen and and sometimes on the other.
Its easy enough to move it over to the proper screen and move the widgets to the right place, just annoying.

Is there any way to explicitly set the monitor for a mate panel at startup?
I’ve searched through gconf and dconf and couldn’t find anything.
The “Make default” button in the display settings also don’t solve this.
I am using the “Eleven” panel layout and compiz.
I think this might be a bug with the place window plugin in compiz, but I like having that enabled
so that windows appear centered rather than under the panel at the top left corner of the screen.
I have already tried all the options under multi output mode in ‘place windows’ in ccsm.
Any help at all would be appreciated.

Thanks

Hi,

this might help, it is generally for Nvidia but you might be able to read something from it should you have a different GPU:

http://jsmylinux.no-ip.org/basic-information/dual-monitors/

Have you tried “xrandr”:

http://ubuntuguide.net/change-screen-layout-settings-in-ubuntu-using-arandrxrandr-gui

To install via a terminal (Ctrl + Alt + t):

sudo apt-get install arandr

I know the above command states “arandr” and not “xrandr” but it is the right command, it will install the GUI for it too!. :smiley:

Thanks for the reply Wolfman

I am using an nVidia gtx570 with 304 drivers. The first link suggests using separate x-screens,
which I suppose will fix the issue, but brings its own limitations.

I have used arandr in xfce before but thought that the mate display settings were a replacement for it in mate.
I’ll give it a try here and see if it fixes the issue.

Thanks.