Missing hardware address in 18.04 ifconfig result Solved


#1

Hi crew,
On updating to 18.04 one of my commercial java programs refuses to start. It’s looking for a MAC address to make a machine number for licensing purposes, and can’t find one so terminates.

I’ve just checked the difference between 16.04 and 18.04, this is an abbreviated version of my results.

Here’s the first line from ifconfig using 16.04
[email protected]:~$ ifconfig
enp3s0 Link encap:Ethernet HWaddr a0:f3:c1:01:c2:7d

A hardware address, completely missing when I do the same thing in 18.04
[email protected]:~$ ifconfig
enp3s0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether a0:f3:c1:01:c2:7d txqueuelen 1000 (Ethernet)

So any ideas how I can fix this please???
It’s a pain having to reboot into 16.04 every time I want to use this program.


#2

18.04 reports the MAC address as ether, ifconfig | grep ether

I dont know if that commercial java program can be modified to grep for ether instead of HWaddr


#3

Thanks pavlos_kairis,
What a silly old fart I am, didn’t even notice the same numbers after “ether”
I’ll email the program author and see what he says. But I suspect I’m a one off and it won’t be worth his time.


#4

So I’ve just had a reply from the author, no promises, but looks like he’s accepted the challenge.


Hello,
This is tricky… I will try to understand what happens.
Regards,


#5

Solved my problem by installing linux-mint mate 18.03, similar software to Ubuntu mate 16.04, but it has longterm support.