Mouse-over on any windows shows black band instead of text

I had posted the issue on Debian Forum, but there’s lukewarm response. Please somebody here fix my problem. Here’s the details post: http://forums.debian.net/viewtopic.php?f=6&t=133385

[quote=“manmath_sahu, post:1, topic:13689”]but there’s lukewarm response. Please somebody here fix my problem.[/quote]… I think it’s best I personally just ignore this.

On-topic – I have the exact same issue although it does look slightly differently. No black band, just … nothing. But 2nd mouseover looks as intended. So far, I have yet to find a reliable solution. To the point I just gave up looking for one, since, to me at least it is a very minor issue at best.

However, switching to a more latency oriented kernel (full ck at the moment, Liquorix is moderately unstable after their switch to bfq-mq) did make it better. It wasn’t the reason I switched, but I did notice a minor improvement with this particular issue.

TL;DR – There are things that might improve the situation but I believe there is no 100% fix for it.

I’m using linux-image-4.9.31-xanmod37. I know this is not a major issue, but an annoyance. Please have look at my post on debian forum and suggest if my installation lacks any package. Because I’ve installed mate desktop with a minimal approach, starting with netinstall iso than pulling in just the necessary packages.

[quote=“manmath_sahu, post:3, topic:13689”]Please have look at my post on debian forum and suggest if my installation lacks any package.[/quote]Think about this logically – If first mouseover is buggy but 2nd mouseover is good, does that suggest to you you’re missing a package? Because, to me it suggests a bug. And with that, not something that has a very quick fix.

Had it been a missing package, one would expect the 2nd mouseover to also be wrong. And the third, fourth, one-hundred-millionth and so forth.

Secondly, xanmod – yeah, that might explain something in and of itself. But, well, that’s maybe just personal bias.

One other thing you might try, although there are no guarantees – is switching between the open source drivers and the closed source graphics drivers. For whichever hardware you might have.

Mine is a Intel Sandybridge G620. So it’s opensource graphics. Does intel provide any closedsource graphics for its graphic chips? If it does please point me the url.

Ok, if it’s a bug. Somebody please suggest me how to file it at a proper place so that it gets resolved soon.

One thing that might be worth noting, or several things actually:

  • You’re on Intel, I’m on AMD but we both have this issue. So, definitely not hardware related. And most likely not driver related either.
  • I have observed this issue in several different Ubuntu flavours. Xubuntu, Ubuntu MATE, Lubuntu. So, it is not DE related.

Conclusion – The most likely culprit, at least to some extent… is X. As in, the display server. For which there simply is no fix. Period. Once Wayland does completely replace Xorg, the issue might disappear completely or might not. Because of a lingering driver component.

Ultimately, I don’t think it is worth your time to be annoyed by. Life is annoying enough on its own.

I don’t see how X is the culprit. For example, this evening I did another debian installation on my friend’s laptop. This time it was full Debian Testing DVD. We chose mate desktop and there’s no such issue. Mouse-Over shows title text properly. That’s why I believe my installation is missing some package. I might be wrong though.

I can guarantee you, it is not related to missing packages. I’m definitely not missing any packages but I’m still seeing the issue and I have been seeing it for years now, in different flavours with different desktop environments across a great number of kernels.

There simply is no way it is related to a missing package.

And the fact your friend’s laptop is fine just proves my point – it’s not worth it. There are a lot of different possible culprits (X, Debian/Ubuntu, Linux itself, drivers), all with varying degrees of likelihood (I still say X is the most likely, since I’ve had more than one issue with that one since switching to Linux, it is time for X to be replaced). Ultimately, the only 100% certain solution I found to fixing it was switching back to Windows but that is not an option for me. So, I learned to live with it.

It never happened my with Ubuntu Mate 14.04. Neither happened on Debian Jessie. Of course, I’ll live with it. Because don’t want sparing time for a fresh installation of either. Just hope It get fixed automagically – maybe after some updates. But it’s better to raise the issue on bugzilla, if somebody has not it already. Anyways, thanks for the prompt response.

Ahem, since this here is the Ubuntu MATE forum, it would be nice if you could reproduce this bug using Ubuntu MATE 17.04, and provide screenshots.

1 Like

Yes, will certainly do.

1 Like

WTF! I installed a fresh copy of Ubuntu Mate 17.04. And lo, there’s no such issue. It took rather long to download and install, but finally fulfilling. But it still intriguing what was wrong with Debian Stretch.
Anyways, thank you all for your prompt response.

If I’m reading this right it looks like stretch is using MATE 1.16. Maybe this bug was fixed in 1.18.

Yes, that’s a possibility.

I do have the same problem sometimes and seems to still exist in MATE 1.18.

It’s been than 24 hours I don’t have that problem. Don’t when it may come up. Will report so when it happens. Now that we know it’s still there in 1.18, we need to file a bug for it.

[quote=“ouroumov, post:15, topic:13689”]Maybe this bug was fixed in 1.18.[/quote]It has almost certainly nothing to do with MATE. I first saw this phenomenon in Xubuntu. Which does not use MATE.

So, in which package does the problem lie to file a bug against it?

[quote=“orschiro, post:20, topic:13689, full:true”]So, in which package does the problem lie to file a bug against it?[/quote]The display server, imo anyhow.