Mouse pointer jumps on clicking touchpad


When clicking my touchpad (simple click) my mouse pointer jumps to the bottom left corner. Not every time but frequently.

OS: Ubuntu MATE 15.10

I: Bus=0011 Vendor=0002 Product=0007 Version=01b1
N: Name=“SynPS/2 Synaptics TouchPad”
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse0 event5
B: PROP=15
B: EV=b
B: KEY=e520 10000 0 0 0 0
B: ABS=660800011000003

How to fix that?


You can try making sure that your software sources download location is set to “Main server” and do a full system update, it might help?:


No, doesn’t help.

Update server is set to main. And updates I did.

Same problem.

Hi Tom,

run this terminal command (Ctrl + Alt + t) which will force any missing dependencies; if any are indeed missing:

sudo apt-get update && sudo apt-get dist-upgrade -f

Restart after running it if anything updates!. :smiley:


I did. There was nothing missing. Still same problem.

Now I made a fresh new install of Ubuntu MATE 16.04. Same problem. Mouse pointer jumps down left.

How did you create your bootable media?, did you burn the disk at the slowest possible speed if you used a disk?, if you used a USB stick, did you fully format the USB stick prior to burning the ISO image to it?.

If you didn’t do either of the above, it might account for your current problem!. :wink:

Hi wolfman.

I always use USB stick. I fully format it before I write the image.

The TouchPad problem is the only problem I have. I am pretty sure its not a problem of missing dependency or image burning.

Its about Ubuntu MATE config. I never have that problem with standard Ubuntu or Debian or FreeBSD or any other Gnu/Linux or *BSD. All tested on the same machine.

But Ubuntu MATE = ALL!

So, lets fix it. And thanks for your ongoing support mate. :smiley:

Hi Tom,

alrighty then, try the following commands and see if that fixes it!:

sudo apt-get --fix-missing install

The above command downloads and installs any missing packages on your system.

sudo apt-get --fix-broken install

The above command downloads and installs any broken dependencies on your system.

Another thought, you aren’t dragging your shirt sleeve over the mousepad are you?, this will cause the mouse pointer to jump around!. :smiley:

Ok. Check.

Commands executed. No dependencies missing or broken. Nothing to do.

And no, no shirt involved.

Problem still the same.


And its not jumping around like crazy. It jumps when I click left (sometimes) on TouchPad exactly bottom left. Always the same.

Hi Tom,

it sounds to me that it might be something mechanical (the notebook itself) rather than something software (OS) related?. :smiley:


I am pretty sure its not mechanical. I only have this problem with Ubuntu MATE. And only with the new versions of Ubuntu MATE.

With 14.10 or 15.04, I don’t remember exactly I never had this problem. It was the version with that very nice backgrounds. :grinning: Where can I find all backgrounds of mate versions? Then I can tell exactly which version didn’t made that problem.

Hi Tom,

install Synaptic if you don’t already have it installed and then use the search function and simply type “wallpaper”, it will show all the available wallpapers (background pics) from current and past version of Ubuntu!. Mark and install the ones you want!. :smiley:
(Be careful about not selecting artwork as it may install other desktop themes that aren’t related to Ubuntu Mate and possibly make it look worse but I don’t know!).

To install Synaptic via the terminal (Ctrl + Alt + t):

sudo apt-get install synaptic

It might also be theme related as you have stated that it only happens with your current version of UM, try changing the theme and see if that helps!. :smiley:

Hi Tom,
Like you said, it is probably not a mechanical problem. But anyway, I recently had a problem with a jumping mouse too. It took me a long time to realize that it had to do with a broken trackpointer. The solution to my problem was simple, to disable it using xinput.

$ xinput list
This command spits out a list of input devices. In the case of my
crippled Dell, one of them was a DualPoint Stick. With the next command,
I was able to shut it down:
$ xinput -set-prop “DualPoint Stick” “Device Enabled” 0

If this solves things for you, you could set this terminal command to execute at boot. It may be your solution and maybe (probably?) not but I felt like sharing this as it definitely helped me.

I have a drawing pad that will cause the mouse to jump around if it is near the touch pad or the keyboard. Could you have outside interference? A bluetooth mouse that was left on in the closet caused this problem on my wife’s conputer.

Tom, I don’t think you have a hardware problem. I have seen this issue on Ubuntu 14.04 LTS when installed on some high end HP ENVY Laptops with nVidia Graphics. And been through about 5 brand new laptops.

I think its related to the video driver. I have been lucky and I think version 14.04.3 LTS worked ok, and was able to use the nVidia driver fine, although it was tricky to get to that stage.

One of these laptops have been fine until an update was performed (hardware driver update), and now I see this problem again.

It is a driver issue - I have also installed Windows on the same Laptops and never see this problem.