Move focus when opening a file


#1

In Caja, when I open a file, focus does not move to that file’s window. I looked at the options in Compiz Config Settings Manager, but the kind of behavior I want does not appear to be an option. My experience with window style operating systems goes back to Windows 95. In all the versions I’ve used since then, including Ubuntu MATE 16.04, the focus behavior has always been when a file is opened, focus is immediately moved to that file. Is there some way to get that behavior back?


#2

I forgot to include that I’m using Ubuntu MATE 18.04.


#3

Hi @Moonguide,

What files(s) opening what application(s)? I tried Caja opening Pluma, VLC and Engrampa. I customize Compiz so reset it to defaults and I still don’t see it here.

Edit: In CCSM, check General Options, Focus & Raise Behavior, Focus Prevention Level. MATE reset default seems to be OFF but the reset button on this option is LOW.


#4

I have discovered that the files that are not gaining focus on opening are LibreOffice files, .doc and .xls. Files of .txt and .pdf do gain focus when I open them.

In CCSM, General Options, Focus & Raise Behavior, Focus Prevention Level is set to off. All of the settings are:

Click to Focus is checked.
Raise on Click is checked.
Auto-Raise is Checked.
Auto-Raise Delay is 500
Focus Desktop is checked.
Focus Prevention Level is Off.
Focus Prevention Windows is !(class=Polkit-gnome-authentication-agent-1)

I don’t see MATE reset default.

At one point yesterday I created some empty files, a .doc, a .xls, and a .txt. They all gained focus when opened yesterday, but this morning only the .txt file gains focus. That seems strange.


#5

Another observation. If I have no other LibreOffice files open and open one in Caja, focus does move to the opened file. However, if I have another LibreOffice file already open, the focus does not move to the newly opened file. It seems to me that this behavior is something that would have to be programmed somewhere.


#6

Good observation. This could get a developer familiar with window controls right to the problem.

However...

I'm seeing this in Marco, not Compiz. I created 2 ODT files in Writer and it behaves exactly as you say. Writer does NOT take focus when 1 ODT is already opened in Writer.

Are you for sure running Compiz? It's in MATE-Tweak which also has the Reset Compiz button I mentioned:

And BTW, the default Window Manager is Marco (Compton CPU Compositor)


#7

I’m using Marco, too, mostly because it’s the default, and I wasn’t aware there were options. I used the Compiz Config Settings Manager based on another website I read, or maybe somewhere else on this forum. It made the point that there are things CCSM can change, even if Compiz is not otherwise in use.

I didn’t see the Reset Compiz button until just now when I tried Compiz for the window manager. I get the behavior I expect with Compiz. With other LibreOffice files open, when opening another, focus moves to the just opened file’s window.

My recollection from a few years ago is that there was something about Compiz that I didn’t care for. I don’t recall what it was. But, since I get the behavior I expect with Compiz, I’ll stick with it for now.

Thanks for helping me through this. I won’t mark it as solved just yet, but will after I’ve lived with Compiz for awhile.


#8

Glad it’s working! But you did find a bug in Marco. To my knowledge, CCSM does nothing when Marco is running.

Compiz has a lot of stuff I do not care for but I’ve been running it for at least 10 years now for the Enhanced Zoom Desktop for my old eyes. Nothing compares. I turn off Animations and especially Grid but always setup the desktop Cube.