Mozilla Addons Problem discussion not found

Dear Group,

I cannot find any talk of the recent problems with Firefox add-ons. It is documented at the mozilla website and says a fix has been released. Does anyone else have issues with this on MATE desktop version of Firefox? Will a specific fix for Ubuntu MATE be released, will it be in the software updates, or something else?

Thank you.

See the discussions that took place here:

Since the problem was related to a server certificate expiring, this hit everyone unexpectedly regardless of version as Firefox couldn't connect to Mozilla's server to prove extensions were legitimate or not (known as code signing).

It's been fixed, and no update is necessary as this was a problem on the server, but it did cause Firefox to disable extensions as a precaution. You may need to close Firefox entirely if extensions are still not loading for you.

Thank you for your prompt reply! I have restarted my computer a number of times within the past few days. Even if not needed, I used Synaptic to reload repositories and update all software. I have three add-ons and they all say that they cannot be verified. I have Ubuntu 18.04 and FF 66.0.3. For me, simply restarting the browser has not helped. Is there anything else I can try? Do I need to uninstall the addons and reinstall them?

According to Phoronix, FF 66.0.4 is required to solve the issue, at least on some computers.

I saw the update on Windows, Android and Manjaro but not on Ubuntu Mate yet.

I'm on 66.0.3 and hit the problem the day it happened. The next day things went back to normal. Granted, I only have 2 add-ons and haven't really been closely following but assumed it was a general certificate expiry problem.

My work Mac did run into the problem today, but after auto updating, add-ons worked again.

I just realised my install had "studies" enabled, which according to their blog post, was used to push an updated certificate.

To provide this fix on short notice, we are using the Studies system. This system is enabled by default, and no action is needed unless Studies have been disabled.


1 Like

OK, thanks. I will check it when I get home.
The FF on the UM18.04 computer of one of my daugthers has problems with uBlock Origin. I didn't notice the issue on the other two computers, though.

My extensions are still not loading in Firefox

I enabled "studies" in the computer with problems, waited half an hour and since the mentioned study didn't show up, I closed FF and opened it again and that seems to force and update. Now all the add-ons are working. Thanks for the link!

1 Like

I am on FF 66.0.3, so you do not need to update the version. I found the "Studies" option in Preferences ...Privacy and Security and enabled it. Trying to enable add-ons did NOT work immediately. I can only assume the studies are pushed out /updated only at certain times. When I cam back in a couple of hours, I had not problem with add-ons. Thanks for the help everybody!

It's still an ongoing issue, although most people have had their issues resolved.