mp3 files vs. Rhythmbox on Ubuntu-Mate 15.04

I have a netbook with 15.04 installed. It will not play mp3 files. I followed the usual advise to install ubuntu-restricted-extras. Still no go. The mp3 files will play fine in vlc player.

I have another PC with 15.04 64 bit installed. It will play mp3 files in Rhythmbox. I do not recall installing the restricted extras on this machine although I had installed some other audio programs and apparently one of them installed the necessary packages. However, I do not know what package I am missing.

In order to determine if it is a 32 bit vs. 64 bit issue I created two virtual machines with VMWare. Neither will play mp3 files in Rhythmbox even with the restricted extras installed.

I have a 15.05 64 bit virtual machine which I created for some security testing. I did not set it up with multimedia in mind. It WILL play mp3 files in Rhythmbox. Same for a virtual macine of 14.04 64 bit (Rhythmbox 3.0.2) - plays mp3 files just fine.

As my objective is to get Rhythmbox working on the 32 bit netbook I will be doing my testing on the new virtual machine and then moving the fix to the netbook. However, at the moment I am at a loss. It does not appear to be hardware related as vlcplayer works in all instances. I suppose I could use vlc but I have been researching Rhythmbox configuration for a specific task.

Any suggestions?

TIA,

Ken

Install the following packages :slight_smile:

  • gstreamer0.10-fluendo-mp3
  • gstreamer1.0-fluendo-mp3

Thanks Wimpy for the suggestion. I find that the packages are already installed. I tried removing and then (re)installing them. No change.

Ken