My desktop icons keep moving

system
desktop

#1

Hello Mate users

Running Mate 16.04 and I thought I’d asked about something that has been bugging me for a while, and that is that a number of icons that I have placed on my desktop keep appearing in slightly different positions each time I boot. I diligently go and line them up each time, sometimes using the “Keep Aligned” option, but they never stay in the place I put them.

Here is a link to an image of my desktop. You’ll see the icons on the right are out of alignment even though they were aligned before I rebooted.

Desktop

Is there somewhere I can set these in a configuration file?

Many thanks.

Martin


Proper alignment of desktop symbols
Desktop icons keep rearranging
#2

I don’t know.

I think any OS has problems aligning icons on the right side of the screen. The “natural” order for desktop icons is up-down, left-right.

You need a program like Fences (Windows only).


#3

Hi. Yes, I have used Fences before on a Windows machine and I liked it. Even without fences though icons I line up on the right side of my work windows laptop always stay in the same place after they have been placed. My mate icons do not appear to remember where they have been placed.


#4

Just a question, do you go normal shutdown like:
click the power icon in top right corner and then press the shutdown button
or do you force your pc to shutdown with power button?

I had this problem only when I had to force shutdown my pc, all icons reset somehow


#5

I have not been able to reproduce this behavior. What theme is that and from where did you download it? I would like to try it to see if it is a problem.

You can also create a new user account and see if it is also affected.


#6

I’m unable to reproduce this behavior under Ubuntu MATE 16.04.1 LTS running MATE 1.12.1


#7

@logical It happens on a software restart or software shutdown. I’m not sure about a hard shutdown as I’ve not done that for some time. I usually just suspend the machine and it is not a problem then.


#8

@v3xx I have BlackMate chosen in Appearance Preferences. The icons of the wooden disks are PNG’s I found on the net which I’ve swapped for the regular ones by right clicking, going to properties and changing the icon in the Basic tab. I’ve not loaded a whole new theme.

I’ll have a go at creating a new user account and I’ll report back what I find.

By the way, just noticed @ouroumov message and I should have said that I did update to Mate Desktop 1.14.1 when it came out. I am not sure if this behaviour existed before then.


#9

I also tried it on 1.14 and again no problem for me.

Your icons shouldn’t be a problem.

BlackMate has been solid for me in the past. I also have been using it in 16.10. Could be a glitch in yours, but we will know more after you try a new user.


#10

@v3xx

Apologies for the delay but I got side tracked.

The good news is that my problem has gone away. I’ll explain what I found, and by chance it worked.

I first created a new user to see if the problem existed in the new account and it did not, any icons I placed on the desktop stayed in the correct position.

Then, later in the evening whilst I was reading some other forum posts I came across a reference to “LightDM GTK+ Greeter Settings” which I thought I would take a look at as I had not used them before.

When I opened the LightDM application, the first drop down on the appearance tab is “Theme”. As I said earlier I am using BlackMate … but this LightDM dialog was set to Ambient-MATE. No idea why, I don’t think I have ever used it before. Anyway I set it to BlackMate, came out of the dialog, rebooted and that was it, my icons had stayed in the same place. I rebooted multiple times moving the icons to check that they stayed put and they did every time so I’m fairly sure it is fixed.

So maybe there is some theme corruption when two different themes are specified.

Thanks for your help.

Martin


#11

In my experiencing, doing that is a guarantee you’ll get the famous “emergency mode” screen.