New system can't run TOR?

Machine: System: TOSHIBA (portable) product: Satellite S855D v: PSKG2U-028005
Mobo: TOSHIBA model: Portable PC v: MP
Bios: Insyde v: 6.40 date: 01/14/2013
CPU: Quad core AMD A10-4600M APU with Radeon HD Graphics (-MCP-) cache: 8192 KB
clock speeds: max: 2300 MHz 1: 1600 MHz 2: 1600 MHz 3: 2000 MHz
4: 2000 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Trinity [Radeon HD 7660G]
Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: fbdev,vesa)
Resolution: [email protected]
GLX Renderer: Gallium 0.4 on AMD ARUBA (DRM 2.43.0, LLVM 3.8.0)
GLX Version: 3.0 Mesa 11.2.0
Audio: Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
driver: snd_hda_intel
Card-2 Advanced Micro Devices [AMD/ATI] Trinity HDMI Audio Controller
driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.4.0-24-generic
Network: Card-1: Qualcomm Atheros AR8162 Fast Ethernet driver: alx
Card-2: Realtek RTL8188CE 802.11b/g/n WiFi Adapter
driver: rtl8192ce
Drives: HDD Total Size: 750.2GB (3.9% used)
ID-1: /dev/sda model: TOSHIBA_MQ01ABD0 size: 750.2GB

Up to date? Welcome set to receive updates too?

As far as I can tell everything is up to date. When I click Tor nothing happens. I have removed and reinstalled with the same results. Everything else, as far as I can tell, is working but the system does seem slow to execute programs.

What is the output when you try running Tor in a terminal? This will give some clues why it’s not working.

/usr/bin/tor-browser-en.sh

[email protected]:~$ /usr/bin/tor-browser-en.sh
cp: cannot stat ‘/home/don/.tor-browser-en/INSTALL/Browser/TorBrowser/Data/Browser/profile.default/search.json’: No such file or directory
[email protected]:~$

If I go to the tor package, click install and then click on tor globe then the browser comes up and works but clicking the browser from Applications menu doesn’t work???

When I tried to run Tor Browser from the terminal it indicated that it could not find file search.jason so I copied it from another system and put it in profile.default it now works. I reinstalled Tor several times but that file never got installed. How come?

1 Like

Can you provide information on the install procedure you used?
I just installed Tor Browser from the software boutique and it worked right away.

I either installed from software boutique or software center I am not sure. Was your install the first time you had tor on your system? Could the file have all ready been there?

First time install of Tor Browser.
Actually it’s been years since the last time I installed anything Tor-related so I’m quite sure there’s no chance whatsoever it could already have been there.

Edit: plus when I look for the file in that path you mentioned I don’t have a file named search.json, mine is named search.json.something

I have no idea why the file was not on my system but I installed / removed tor several times trying to get it to work. As I indicated this system I just set up with ubuntuMATE and was installing several programs. The only one I had an issue with was Tor.

Be sure to purge everything from the old config before reinstall.

Take a look at this : https://www.youtube.com/watch?v=5X6wW4kxXR0

Or simply go to youtube and search “install tor browser ubuntu 16.04”, there are many good videos.

If you want to help others to help you, you should explain how you installed and show messages during install, and show error messages at run time. Showing the hardware doesn’t really help for this problem.

Good luck!

Tor Browser is not working anymore since the latest update (today) through the Software Updater. I am also a bit confused why I sometimes receive Tor updates through the browser itself and sometimes through the Software Updater. Are there any potential conflicts? I have tried re-installing through the Boutique with no success. Can someone else confirm that the new packages are broken?

I generally don’t use the tor browser, but rather a tor, proxychains, and firefox combo. That way i can run firefox (and other programs) with multiple proxys rather than just the tor proxy (depending on how you set up your proxychains). So when i run firefox i simply…

proxychains firefox

From what i’ve experienced, the best way to install tor is:

Add the following entry in /etc/apt/sources.list or a new file in /etc/apt/sources.list.d/:

deb http://deb.torproject.org/torproject.org wily main
deb-src http://deb.torproject.org/torproject.org wily main

Then add the gpg key:

gpg --keyserver keys.gnupg.net --recv 886DDD89
gpg --export A3C4F0F979CAA22CDBA8F512EE8CBC9E886DDD89 | sudo apt-key add -

The install it:

apt-get update
apt-get install tor deb.torproject.org-keyring

Then if you want the tor browser, get it from their site directly:

https://www.torproject.org/projects/torbrowser.html.en

Thanks @larryb for taking the time describe a manual installation. But the reason I use the Software Boutique is that it allows me to save time and I don’t always want to use the terminal to install or update software. Since the last update something went wrong, so I am wondering if anyone experiences the same problems. I have Tor Browser installed but it won’t launch and previously never had any problems with it. Is there anything wrong with the package in the Software Boutique? @lah7

I here ya…but i wouldn’t use a ubuntu universe installation because the tor site says:

Do not use the packages in Ubuntu’s universe. In the past they have
not reliably been updated. That means you could be missing stability
and security fixes.
(from: https://www.torproject.org/docs/debian.html.en)

Where I live I do not have access to their website. The only way for me to install it then is through the Boutique?

I deinstalled Tor Browser through the Software Boutique and reinstalled it but the application simply won’t launch. This is very strange because on my other laptop (same configuration, set to receive latest updates, etc.) it works without any problems. I guess it must be somehow related to some files not being completely removed from my laptop. And removing and reinstalling the entire Welcome application didn’t help either.

I had a similar issue on Linux Mint when using the same PPA that Ubuntu MATE’s Software Boutique uses. I’m not sure if my experience applies to anyone in this thread, but here is how I resolved the problem:

While attempting to perform a clean reinstall, I noticed that even though I had purged the TOR Browser’s package it still left behind its hidden folder in my home directory (.tor-browser-en).

I deleted that folder and its content and then reinstalled the TOR Browser. It then launched successfully after that.

2 Likes

Thanks so much for pointing me to this! It worked perfectly! You literally saved me hours.

2 Likes

I have not been able to open the link you provided. My previous experience with the Tor Browser is that updates get pushed through both, the PPA that the Software Boutique refers to and updates that Tor Browser receives directly through its internal update function. But to be sure, it would be great if someone else can look into this to confirm whether there are security risks due to late updates. From a security standpoint many things can also go wrong with manual installations. Especially when it comes to verifying files and making sure that the website you see is the one you intend to see.