No additional drivers available

after a fresh install of ubuntu mate 16.04 i don’t see any additional drivrers, i enable all repositorys and still not showing.

This not happen before, i use intel-microcode

I tried with these .isos

and netinstall.

and none works

make sure you do an update/upgrade and then take a look at the add’l drivers.

already did

Try to run the command ubuntu-drivers from a terminal (add -h to show the help)
for example:

ubuntu-drivers list
ubuntu-drivers autoinstall
ubuntu-drivers devices

It does not work, i installed intel-microcode and iucode-tool but still not appear.

I’m on 16.04 installed May 2016 and right now, Intel microcode no longer shows in Additional Drivers.

I highly suspect this is the result of recent meltdown/spectre updates that came, went and were modified. Of course, Intel microcode is a key part of mitigations and it’s been a mess, so to speak. Intel put out some bad code and no one trusts them at this point.

EDIT: And this may be processor dependent. Mine reports Intel® Core™ i7-4790 and I believe it’s Haswell.


Same here, only the nvidia card is shown in my UM 16.04.4

1 Like

I was just looking at my synaptic history searching “microcode”. Here’s almost 2 years worth…

Aug 25 2017  intel-microcode (3.20151106.1) to 3.20170707.1~ubuntu16.04.0
Jan 11 2018  intel-microcode (3.20170707.1~ubuntu16.04.0) to 3.20180108.0~ubuntu16.04.2
Jan 22 2018  intel-microcode (3.20180108.0~ubuntu16.04.2) to 3.20180108.0+really20170707ubuntu16.04.1

This does not directly affect Additional Drivers but shows how the Jan 11 update was backed out Jan 22 (note the creative versions). I’ll bet that’s when it disappeared in Additional Drivers.

That Jan 11 update did cause problems (none here, however). So I’m sure microcode control via Additional Drivers was changed a bit.

1 Like


are you using an Intel GPU?.

To install the Intel Microcode package, use the following terminal command (Ctrl + Alt + t):

sudo apt install intel-microcode

The above is for both 32 and 64 bit versions. :smiley:



already did, but seems there’s a new version (3.20180312.0~ubuntu16.04.1) but still not showing in additional drivers.

Hi @avestruz123,

if you want to install the Intel package manually, use the following terminal command (USE AT YOUR OWN RISK!):

sudo apt install intel-microcode

So here 's the problem:

ubuntu-drivers-common (1: xenial-security; urgency=medium

  • Drop the detection plugin, as exposing microcode
    packages will not be necessary once kernel metapackages have a hard
    dependency on them
    • remove detect-plugins/
    • update UbuntuDrivers/
      – Chris Coulson Tue, 30 Jan 2018 13:58:58 +0000

Hi @avestruz123,

try changing your software sources download location to somewhere else and updating again, I use the “Main Server” myself, if yours is set to your country, try changing it to “Main” per the update guide linked below: