No hdmi sound on b+


#1

Have raspberry pi b+ and have installed retro pi on one sd card and Ubuntu-mate on the other
As you may suspect retropie sound through hdmi working and sound on Ubuntu-mate is not.

I am looking for a few tips as I am have followed many of forums but still no further.
Last attempt was in terminal - sudo amixer cast numid=3 2


#2

I know nothing about raspberry pi, but I think UM18.04 did a poor job with sound management, especially with those who frequently use HDMI. Every time I use HDMI I need to manually change the hardware sound settings. I need to do the same when reverting back to a non HDMI environment. Not sure if you have the same settings to change.


#3

Have you switched the sound from headphone jack to HDMI using raspi-config ?

Mickey :slight_smile:


#4

Pi3 b+? If its that ubuntu mate doesn’t suport that at this moment.


#5

Yes I had gone through config and selected force hdmi


#6

Thanks for reply. I could not find any confirmation about hdmi usage on the b+


#7

@eyecbeer

When I most recently ran my Pi 3B+ (Raspbian), I had to run sudo modprobe snd-pcm-oss to get sound working through HDMI.

Usually when I have a new ARM system I have to go through the dance of repeatedly running speaker-test while trying things listed on https://wiki.debian.org/SoundFAQ whether that’s modprobing snd-pcm-oss/snd-bcm2835, installing timidity, alsamixer, or oss-compat. Have you ruled all that out?