Notify-send/notify-OSD is still working on 18.04? Replacement?

Hi! I have ubuntu mate 18.04, up to 16.04 I was used to send notification from bash script using notify-osd, but now I see that the default notify-send is not working like before and notify-osd is not properly working on 18.04.
The notification box that produce notify-send is quite ugly (very small and has a blue landscape) and I'm getting crazy on the internet looking for a way to customize it, furthermore there is no way to display an icon in the box.
Can somebody help me, please?

Notify OSD seems to still work in 18.04. From a fresh install after installing notify-osd:


If you've upgraded to 18.04, you could try reinstalling so it reconfigures itself:

sudo apt install --reinstall notify-osd notify-osd-icons

I'm aware there is a notifyosdconf which is a modified notify-osd adding customisation options - I'm not sure if it still works today:

Thank you for your reply lah7 .
My installation is a fresh installation from scratch, no compiz, no strange ppa. I use marco wm (no compton).
I attach two screenshot, the first one is without notify-osd, the second one is with notify-osd installed.

I don't quite recognise which notification is rendering that, but notify-osd doesn't look like it's running. Maybe try removing MATE's notification daemon:

sudo apt-get remove mate-notification-daemon

Check there is a notify-osd process running in System Monitor:

If there is not, try running it via the terminal, and try notify-send again.


If this works, add the command to Start-up Applications. It could reveal an error, like another process listening for notifications:

** (notify-osd:2841): WARNING **: 22:30:36.208: Another instance has already registered org.freedesktop.Notifications

** (notify-osd:2841): WARNING **: 22:30:36.208: Could not register instance

I removed mate-notification-daemon, but nothing has changed.
I rebooted the system, always the same.
In system-monitor I can't find notify-osd, but if I try to start it from a terminal I receive a message that another instance is already registered, impossible to start a new instance.
I tried to uninstall and re-install, nothing.
Something is wrong, but I can't understand what.

ok, Got it.
A couple of months ago I tried i3 wm and, after uninstallation, it left a package called dunst that interferes with notifications.
I removed the package, logged out, logged in and the problem was fixed.
Thank you anyway.