On boot I get error message Couldn't get size: 0x800000000000000e UEFI


On BOOT I get error message “Couldn’t get size: 0x800000000000000e”

On BOOT after GRUB:
Couldn’t get size: 0x800000000000000e

On LogFile-Viewer
Loaded UEFI:db cert ‘Canonical Ltd. Master Certificate Authority: …’ linked to secondary sys keyring
Couldn’t get size: 0x800000000000000e

MODSIGN: Couldn’t get UEFI MokListRT

How can I fix it?

Please help!

What version of u untu mate do you use and what video card do you have? If you tipe your problem in google you will find tons of fixes from disable secure boot (bios) to others but depends on what do you have.

I disabled SECURE-Boot in my BIOS.

CSM-Mode in my BIOS is “enabled”.

Ubuntu-Mate Version is: 18.04 LTS

My video card is: GeForce GTX 1060 6GB

Ubuntu-Mate Version is: 18.04 LTS
Kernel: 4.15.0-34-generic

After I updated packages of the Update-Manager in Mate. Rebooted my OS and
then “the error” appears…

On WWW I readed about that is a Kernel-Bug with error “Couldn’t get size: 0x800000000000000e”

Is there a chance to fully REMOVE "UEFI incl. UEFI-BOOT partition and the UEFI-Boot-Manager in Grub?
When yes, how?

Error-message is gone after upgraded to last Kernel.

I have got this problem now!
I installed ubuntu 18.04 some time ago and after a long time using it the other day give me this problem. Now it's impossible to boot ubuntu. I have installed the latest version (19.04) and it's too not working, the same error.
I tried too to change the BIOS disbling Security Boot but nothing happen....
Windows 10 boot normally.
I need a solution, please!

@ ripeamado,

I don't really know. Maybee a kernel thing.
I did some testing and decided to remove UEFI
completely because I often had UEFI error messages in the past.

What I've done.

I disabled UEFI and switched back to CSM in UEFI-Bios.

After that I removed all UEFI stuff from Ubuntu Mate and now I don't have the problem anymore with UEFI error messages like "Couldn't get size. . ." etc.

!!!BEFORE that, make a backup of your harddisk like Acronis True Image etc.!!!
At your own risk!

Here's a how-to, but only in german language.

After that you have to remove all these packages:

sudo apt purge --remove fwupdate fwupdate-amd64-signed fwupd mokutil shim-signed fwupdate-signed libfwup1 grub-efi grub-efi-amd64-bin grub-efi-amd64-signed shim-signed
sudo apt purge --remove libfwupd2 libsmbios-c2 shim sbsigntool
sudo apt purge --remove efibootmgr libefiboot1 libefivar1 secureboot-db
sudo apt purge --remove linux-signed-image-generic linux-signed-generic
sudo apt purge --remove libelf-dev elfutils libasm1