Open mate terminal minimized


#1

Is there a way to open a mate terminal minimized?


#2

Quick look into MATE Terminal shows that it does not have such options.

But may drop-down terminal as TIlda (or Guake) be an option for you?

Such terminals are activated by <F12>:

You can install Tilda with

sudo apt-get install tilda

#3

one solution is to use devilspie

I recommend using the GUI version


#4

I want to start it minimized on each boot up.


#5

gdevilspie is not in the repository in synaptic. I found the deb file but...

sudo gdebi gdevilspie_0.5-3.2_all.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: python-wnck


#6

I have never heard about GDevilSpie, but you can install it with the dependency manually:

wget http://mirrors.kernel.org/ubuntu/pool/universe/g/gnome-python-desktop/python-wnck_2.32.0+dfsg-3_amd64.deb
sudo apt install ./python-wnck_2.32.0+dfsg-3_amd64.deb

wget http://mirrors.kernel.org/ubuntu/pool/universe/g/gdevilspie/gdevilspie_0.5-3.2_all.deb
sudo apt install ./gdevilspie_0.5-3.2_all.deb

and then proceed with gdevilspie:

gdevilspie

Note: tested on Ubuntu MATE 18.04.2 LTS, 18.10 and upcoming 19.04. Reported bug 1820507 about missed gdevilspie package.


#7

Thank you very much.


#8

Gdevilspie is confusing to me.

Is the terminal supposed to start minimized every time I start it?


#9

What the above will do is open all instances of the terminal minimised. However, to only have it minimise a particular instance of the terminal, you could implement it as a script something like this:

Set up a Gdevilspie entry for mate terminal to open minimised. Then close the Gdevilspie GUI.

Then write the following bash script.

devilspie &
mate-terminal &
sleep 2
killall devilspie

The above script runs devilspie with the condition that mate-terminal opens minimised. Mate terminal is then opened minimised. Then devilspie is killed, leaving the newly opened mate terminal minimised. But, any another other instances of mate terminal you subsequently open will open maximised as per usual.

You could then run this script at startup

One final thing to note: if you wish mate-terminal to open at a specific location, then you need to add the following line above "mate-terminal &"

cd <path to folder>


#10

The script does not work.

It just opened the default window.

I noticed that is says the devilspie daemon is not running despite my checking the Start devilspie deamon automatically.


#11

It works for me, I tested it before posting:

The first thing you should do is uncheck the option to start devilspie automatically. That is not how I instructed you to do it. Instead devilspie should be started in the script and killed in the script. That way, its use is limited to the specific job you need it to do.

Additionally, go into your .devilspie folder and open the ".ds" file that was created for minimising the terminal and check it has the following content in it:

; generated_rule terminal
( if 
( begin 
( is ( application_name ) "Terminal" )
) 
( begin 
( minimize )
( println "match" )
)
)

One other thing you might want to adjust is the "sleep" command in your bash script. I tried it with no sleep command and with a sleep command of 1 and it failed to allow devilspie enough time to control the terminal. A duration of 3 was more than necessary. 2 was just right. But, depending on the speed of your PC and/or the number of other processes you have running at login, you may wish to increase the sleep command duration


#12

Thanks Steve.

Works great.


#13

Glad to hear you got it working Fixit7