Oracle VirtualBox error on 18.04 : driver not installed(rc=-1908)

I've been installing VB from software butique and try to fix this issue aswell thru different commands available at other sites but still nothing works.

Do you know how to fix this?

First step is to make sure Virtualization is supported and enabled in your BIOS.

Boot into BIOS and in your settings make sure Virtualization is turned on. Actual location and terminology will vary from various manufacturers


Let's check that first and go from there

Enabled It.

Still got this

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please reinstall virtualbox-dkms package and load the kernel module by executing

'modprobe vboxdrv'

as root.

If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system's documentation for more information.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

Do you have secure boot enabled?

I would uninstall VirtualBox through Software Boutique

Afterwards I would update the system and then reboot.

After the reboot please try the installation again.

I'd suggest disabling secure boot first in the BIOS, it's normally under the Boot tab. Secure boot prevents unsigned kernel modules from loading.

The easiest would be to follow @franksmcb's suggestion and reinstall via Software Boutique.

VirtualBox installs a DKMS module which builds a driver for the running kernel. You can use a command to check if there is one installed.

$ dkms status
vboxhost, 6.0.10_OSE, 5.2.11, x86_64: installed

Disabling secure boot might be enough to enable the driver to load.

1 Like

Frankly, I never managed to get up and flawlessly running VirtualBox version which is bundled with Ubuntu. VirtualBox from worked perfectly though.
Well, sometimes, generally after major kernel updates, VirtualBox complains that it has no appropriate module. I.e. I see that it refuses to start and I run it from command line. That is the trick: VB not only throws an error message to console, but prompts a command which I have to issue for recompilation of broken module, etc.

two things:
A: use the correct modules for your version of Vbox
B: make sure you are in the Vbox group permissions.