Panel not showing up after boot

You can simply press ALT+F2 and type this to restart the panel:

mate-panel --replace

It sounds like the window manager is interfering. Which one are you using? (This can be checked in MATE Tweak under the Windows category).

Try another window manager, it wouldn’t surprise me if it’s Compiz.

1 Like

Have you run a full system update?:

Ah…finally I managed to find this request again. :stuck_out_tongue: Well it currently is MARCO (Compton-GPU-Komposit). Doing updates regulary.

Hi @Kepos,

is your problem solved?. :smiley:

Not yet, thx request. Thought I got rid of it for a time, but actually I ran back into it. My solution was to just reboot till it works…mostly 2-3 times needed for.

On my system i have a similar problem. After boot the panels appear, but not the desktop icons. There is only a wait-cursor.
After reboot it works again.

When the desktop and icons hang, it sounds like a fault with Caja.

You could use this command to restart it:

caja -q

However, I’m not sure if Caja is responsible for @Kepos’s problem.


Thank you!
I will try your tipp at the next time.

Ok, this seems to be a problem with caja and Kepo’s problem seems to be a bug in mate-panel.

(I am using Ubuntu MATE 16.04 with MATE DE 1.14.1)

Thx all for your posts. Unfortunately @Etamuk’s problem seems a bit different to mine.
By thinking about chronology I allways see Mate’s Plank to be up before any panel. Probably running Plank on automatic start at this point might disturb full loading of usual panel?
Sorry, but I’m newbie to Mate, so I can’t dig more into the problem then to just lay out what I see.

A boot or start delay can be added to plank, but to be sure this is plank related can you run with plank removed. You could also check the guest session for same problem.

1 Like

@anon42388993 what you mean with guest session? guest is loading without Plank loading auto?

Correct, the Guest Session will load up without Plank.

Hi @kepos,

you could try changing your software sources download location and running updates again!, this might fix the problem?:

Started guest session, success. Then I tried usual loading just without Plank being autoloaded, success.

Seems like autoloading Plank causes the problem…

Ok, try adding some delay to the startup. Add a line to the autostart file:


Thats 15 seconds of delay, probably too much, just a guess.

1 Like

@anon42388993 thx the notice. It didn’t happen recently and I’m not allways on Mate. Found the autostart object and start now with 5sec delay.

Let us know if this works.

Well, so far the problem didn’t fire again. Thx to your workarround!
But I have not tested intensively, as I still do not see AMD driver for my card and therefore using Windows mostly at the moment. Let you know if I get more data.

BTW, Mate 16.04 with pretty much same setup doesn’t cause this problem to fire on my laptop (L650D), except one single time. I have no clue what may be the difference…

1 Like

This thread may get solved yet :slight_smile:

1 Like

New update: so far the problem didn’t occure, so I’d rate your advice to solve it.
You may mark your suggestion, so other’s may also profit from it.
Thx again for your assistance, @anon42388993