Permission Error on /dev/ttyUSB0 recently appeared

I'm using a program called CHIRP to program frequencies into an amateur radio. It's been working since UM16.04 LTS with the same converter. It requires a USB-to-serial converter to talk to the radio.
I ran lsusb and this is a snippit from that output.....
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
**Bus 001 Device 003: ID 1f75:0621 Innostor Technology Corporation **
Bus 001 Device 009: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
The OS clearly sees the Prolific device.
I get the following error msg now.
[Errno 13] could not open port /dev/ttyUSB0: [Errno 13] Permission denied: '/dev/ttyUSB0'

I removed the program and installed a much older version ,,, same Error results
This is my current system
Release 18.04.2 LTS
Kernel x86_64
also ran ls -l
-rwxr-xr-x 1 root root 4483 Sep 25 07:19 /usr/bin/chirpw
my groups
spanky : spanky adm dialout cdrom sudo dip plugdev lpadmin sambashare wireshark
stumped. Suggestions?