Please Help! Webcam Suddenly Stopped Working

Hey all, I film YouTube videos from my Lenovo Yoga 2 Pro laptop using its built in webcam. I've never had any issues with it on Ubuntu MATE or any other distribution.

It was working yesterday, but now both Cheese and Guvcview will not even recognize it so I checked lsusb and I don't even see that the system is recognizing it. Below is a screenshot showing the errors from guvcview and cheese plus the output for lsusb.

Please can someone help me? This is detrimental to my workflow.


does your laptop have an FN switch; webcam related button on the keyboard that you accidentally switched off?.

What version of Ubuntu Mate are you running?.

Did this happen after and update and have you tried changing your software sources download location and updating again?:

It has an FN switch, but I’ve been trying it with every F key and none of them seem to turn it back on. Also, after I got the error I formatted my drive and installed Linux Mint Rosa xfce and got the same errors. Now I’ve switched back to Ubuntu MATE 16.04 with a fresh install - definitely seems like a hardware issue, but It’s hard for me to think that the camera is broken considering my laptop has not moved anywhere in ages. I’m completely dumbfounded with this one.

Hi Justin,

if it is of any help, a friend of mine has an HP laptop (I can’t remember the model) and his webcam just simply died on him, it didn’t work with Windblows or Linux, it may well be a simple case of a dead webcam, even though like you say, you haven’t moved it anywhere!.

Do you still have Windblows on it and is it working with that?. :smiley:

1 Like

I’m hoping that’s not the case, but it’s looking pretty bleak for me at this point. I don’t have Windblows any longer. I kicked it to the curb a few months ago. Thanks for responding and at least trying to help me figure something out. :disappointed_relieved:

Take a look here, it might be a bug which affects you too?:


You might find something here to help you?:

It’s possible, but I think it’s unlikely due to the fact I’m getting the same error with multiple kernels. However, I found out that many people with this laptop are having the same issue.

It appears as though the issue may have been caused by the hinge pulling the plug away from the motherboard over time. I’ll post the link for the unlikely event that someone has the same issue with this laptop model.

Of course, this laptop needs a micro-torx screwdriver which I don’t have, but at least I have some hope now! Thanks again for the help.


Good luck!. :smiley:

1 Like