Printing Trouble

I have a Brother HL2040 b/w laser printer.

I installed the printer from the included software first, then tried downloading the .deb files for the printer from the Brother website. I ran the dpkg and bash commands as in the instructions on the Brother site.

I tried all 4 USB ports on the Dell Latitude E6400 laptop, that didn’t work.
I tried them in combination with each of the two instances of the printer visible on the Printers page in Control Center.
Tried other computers with the printer, it works.
Tried multiple ports on this printer, it didn’t work.
When I had linuxmint on the computer, it worked, recently installed Ubuntu MATE.
Most everything else seems to work OK.
The printer usually “revs up” audibly when I attach a laptop to the USB cable, but no response with this unit under MATE.

Control Center/Printers and http://localhost:631/printers both show two printers (slightly different name, I think the second was the one I installed first with the MATE control center > printers > add tool, and the other is the one I installed with the command line tools from Brother.

Any advice appreciated, thanks!


Hi Jim,

install Synaptic if you don’t have it already:

sudo apt-get install synaptic

and then search for “brother” and install all packages showing and see if that helps!. :smiley:

See also:

Thanks so much, Wolfman, I got it to print, just once, but I think you gave me enough of a start that I can fiddle with it and get it working consistently

1 Like

Hi @echeddar,

if you open printer preferences in the Control Centre; there should be options for you to play with!, good luck. :thumbsup: