Problem printing to Windows networked printer

Just installed Ubuntu Mate on an ancient Sony Vaio laptop and all was going ok until I tried to install the printer.

I have followed the instructions here to try and add a printer on my local windows network but when I try a test print nothing emerges from the printer. I tried first the System > Applications > Printers > Add > Network Printer > Windows Printer via SAMBA option and when that didn’t work tired to set it up using the IP address under the Find Network Printer option. The firewall on my laptop is turned off. The printer I am trying to connect to is a RICOH Aficio MP C3300. The device URI as it appears in printer properties is ipp://192.168.38.5:631/ipp.

When I hit test print an error message flashes up at the top right of the screen but is almost instantly replaced by a message telling me the document has been sent to the printer - this happens so quickly I have no chance of seeing what the error is. I’ve been trawling the internet all day trying to work out what is going on and as a result of this did take a look in the CUPS error log and saw a reference to ‘error 32 - broken pipe’ but googling this didn’t help me much. Can anyone enlighten me as to what steps I should take next? (Bit of a noob to Ubuntu, as you may have guessed.)

Thanks, Alistair.

Hi @Alistair67,

a “broken pipe” means it isn’t making a connection, take a look at the following link which might help you?:

https://help.ubuntu.com/community/NetworkPrintingWithUbuntu

Hi @wolfman,

Thanks for your response. The document you sent me a link to is the one I
linked to in my original post. As I said, I have followed the instructions
there under the heading Printing from Ubuntu, but no dice. I looked at the
troubleshooting section as follows;

  1. Bypassing firewall - There is no firewall active on my laptop and I
    opened the 631 port on the network server’s firewall. nmap shows the
    printer to have port 631 open.
  2. Networking issues - The subnet mask dhcp is providing is 255.255.255.0
    which is the same as the network server and the printer are using.
  3. IP Address - the printer has a fixed IP address, It is that which I am
    using to try and connect.
  4. IPv6 - presumably not relevant as it is not the Ubuntu machine that is
    serving the printer.
  5. MacOS X 10.5 - not applicable

If you have any other ideas about what might be causing the issue, I’d be
glad to hear them.

Regards, Alistair.

Hi Alistair.,

if you have the printer connected via a USB cable, try changing the USB port and connecting to the network again, that will often cure the problem!. :smiley:

Hi wolfman,

The printer (it is actually a multi-function photocopier) is connected to
the network via an ethernet cable and is receiving print jobs from the
windows machines on the network just fine.

cheers, Alistair

Hi Alistair,

maybe this will help?:

Hi.
I'm confused about what this network server is.
Please clarify something:

printer ---> |
             |
laptop ----> | NET / 24
             |
server ----> |

Or...

    laptop ----> | 
                 | NET / 24
    server ----> |
         |
         v
     NET / 24
         ^
         |
      Printer

Hi ouroumov,

I believe it is the first configuration:

printer ---> |
|
laptop ----> | NET / 24
|
server ----> |