Problem setting up mysql

it does not work, you can upload text only, not zip files.

example: cat /var/log/mysql/error.log | nc termbin.com 9999

1 Like

What a pain these things are. Text is not good to attach in email but is needed here.
I hope this will work
https://termbin.com/2bk4

You do not attach text in email.

You have a file /var/log/syslog, text, showing the activity of your system. You send this text file to a server (termbin.com ) to a specific port (9999), termbin.com stores that text file for a week (and then deleted) and provides a url for you to read that file. That way, you can share data from your pc for others to review.

If you want to share images, you upload to imgur.com and provide link.

You can do the same with the commands @ricmarques suggested, save the journal output to a file then cat that file as I described above. The mysql status is just 10 lines of output.

This is NOT your first day with Linux, right?

Back to the mysql issue, it shows you still have mysql 8.4 running
Cannot downgrade from 80401 to 80037
(you can read this as version 8.4.01 to version 8.0.37
there are pieces of 8.4 and the system cannot downgrade to 8.0).

My original suggestion was/is, remove everything mysql from your pc with , reboot, verify there is no mysql running in your pc, then do the usual install.

2 Likes

(Server status and Dashboard)

1 Like

You are right I do not attach text in email. That's why I tried to use termbin with a zip file.
What I used the second time was the concatenated text from the three commands Ric advised. Your information about sites enabling file share (text or images) is ver useful. Thank you.

I can well believe that the issue is elements of the wrong mysql persisting. But I did try to remove all things mysql, and start again, twice. The problem therefore becomes how to ensure all the wrong files etc are gone. Help with that would be appreciated. What I did was use sudo synaptic and ask for complete removal of mysql-server and other entries of installed software with names starting with mysql. Apparently
that was not good enough.

I have been running Unix and then various shades of Linux since about 1984 (the first being Slackware). But I am not a system programmer and I find the current generation of the software much more opaque than earlier material.

1 Like

Hi again, @mahmacc (Malcolm MacCallum) :slight_smile:

I think the best I can suggest now for your current situation is to:

1st - Follow all the steps including the "(Optional)" ones from the following article:

https://linuxbeast.com/blog/how-to-completely-remove-purge-mysql-database-from-ubuntu-22-04/

2nd - Run the apt search mysql-server command and make sure that the output that you get is only the following one (if you find anything related to MySQL Server version 8.4 or 8.4.1, then there's still a problem in the "apt" software package repositories that are configured in your Ubuntu MATE installation):

$ apt search mysql-server
Sorting... Done
Full Text Search... Done
default-mysql-server/jammy,jammy 1.0.8 all
  MySQL database server binaries and system database setup (metapackage)

default-mysql-server-core/jammy,jammy 1.0.8 all
  MySQL database server binaries (metapackage)

mysql-server/jammy-updates,jammy-updates,jammy-security,jammy-security 8.0.37-0ubuntu0.22.04.3 all
  MySQL database server (metapackage depending on the latest version)

mysql-server-8.0/jammy-updates,jammy-security 8.0.37-0ubuntu0.22.04.3 amd64
  MySQL database server binaries and system database setup

mysql-server-core-8.0/jammy-updates,jammy-security 8.0.37-0ubuntu0.22.04.3 amd64
  MySQL database server binaries

3rd - IF you find something in the apt search mysql-server output that is related to MySQL Server versions 8.4 or 8.4.1, then: please remove the "offending" MySQL 8.4 repository from your /etc/apt/sources.list file and/or from the associated file in the /etc/apt/sources.list.d directory, if that's the case AND then run sudo apt update

4th - Install (again) the "mysql-server" package by running the command sudo apt install mysql-server

I hope this helps :slight_smile: Please, keep us posted.

1 Like

Followed that advice and it all now seems to be fixed. The optional step appears
to have been crucial. I now get:

% sudo systemctl status mysql

● mysql.service - MySQL Community Server
Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2024-07-09 21:15:49 BST; 21s ago
Process: 216280 ExecStartPre=/usr/share/mysql/mysql-systemd-start pre (code=exited, s>
Main PID: 216289 (mysqld)
Status: "Server is operational"
Tasks: 38 (limit: 18700)
Memory: 365.7M
CPU: 607ms
CGroup: /system.slice/mysql.service
└─216289 /usr/sbin/mysqld

Jul 09 21:15:48 Bianchi6 systemd[1]: Starting MySQL Community Server...
Jul 09 21:15:49 Bianchi6 systemd[1]: Started MySQL Community Server.

Thanks very much for your help, Ric and Pavlos

2 Likes

You're welcome, @mahmacc :slight_smile: I'm glad the instructions solved the problem you were having setting up MySQL Server. Thanks for letting us know.

1 Like