Problem uncompressing files


#1

I’m having problems un compressing files in Linux that un compress just fine under Windows 10 with winzip.

I’ve tried 4 different programs, Archive Manager, Engrampa Archive Manager, xarchiver and P7ZIP 16.02 [64-bit].

With Archive Manager, Engrampa Archive Manager and xarchiver I get these errors.

With P7ZIP 16.02 [64-bit] it shows no files to un compress.

The same files un compress just fine under Windows so they are not corrupt.

How do I fix this problem?

Thanks.


#2

Rar is pretty proprietary–and not supported under Engrampa. Apparently one has to pay a licensing fee–but the developer makes uncompress-only clients available for free.

Have you tried RARLAB’s official package for Linux? It is available here:

https://www.rarlab.com/rar/unrar_5.2.5-0.1_amd64.deb

It may also be in official repositories, or you could install manually.


#3

The first photo shows you’re trying to unzip files in / if that’s the case , you need root access.


#4

What is the program called?
When I installed it it said it was available in the repositories and suggested it be installed there but did not say the name of the program. How do I launch it? When I right click on a rar file I don’t see any new choices for programs to use with the file.


#5

UNRAR There are two versions in the repositories one free and one non-free. Both are older than the version on the website.

Manually installing files from debs is, for me at least, a last resort because it can break update dependencies. However, you are unlikely to ever have another program depend on this one.

Have you eliminated @pavlov_kairis comment as a cause? That is a good catch to notice the directory in the screenshot. None of the archive programs would work if they do not have write access to the directory.


#6

I think I have that one and it does not work.


#7

hehehehehehe… :smile: