Problem with black screen after inactivity

Hi, I am a pretty new Linux user. I am running Ubuntu Mate 18.04, on a Lenovo ThinkPad x250 laptop. Getting it up and running has generally been very smooth, but I have run into a problem with the screen going black after keyboard/mouse inactivity for about 10-15 mins (including watching video).

This didn't seem to be the case originally, and seems to be a problem that has developed in the last few days.

When the screen goes black, the computer seems to still be working (audio from video continues, and can be started/stopped pressing the space bar, and audio can be turned up and down with the relevant buttons) but I can't wake the screen by pressing the keyboard keys or moving/clicking the mouse, or by hitting the power button.

After digging in forums, I had a go at pressing the Ctrl + Alt + F1 key when the problem occurs, and this does take me into a terminal screen ok, and then I can get back safely to the GUI by pressing Ctrl + Alt + F7, so overall I won't be losing unsaved work with the problem. However, I would like to be able to control power management (and I'd really like a nice screensaver!)...

I've tried changing settings in the Screensaver and Power Management preferences in the Control Centre, but these don't seem to have any effect. I've tried lengthening the "Regard the computer as idle after" time in the screensaver panel, but this doesn't seem to make any difference, and in fact the screensaver doesn't kick in even if I set it shorter than the time that it takes for the screen to go to black... I've tried unchecking the "activate screensaver when computer is idle" and "Lock screen when screensaver is active" checkboxes. I've also made sure that the "Put display to sleep" time in Power Management is 1 hour.

I did install the xscreensaver package, and for a while this was working fine; it's only more recently that it seems to have become a problem.

Does anyone have any ideas about what the problem could be, or what I might be able to do to sort this out?

With thanks in advance, and apologies if there is already an answer to this somewhere that I couldn't find.


Sometimes screen saving options are turned on in BIOS/UEFI. That may unpredictably mess OS screen saving options. As the first option I would like propose to verify BIOS settings and turn off its screen/power saving options, if any.


Thanks very much for your help Gene. Strangely, after having this problem consistently for a couple of days, I don't seem to be able to replicate the symptoms, today... I'm not sure what fixed it -- just about the only thing that I did except for continued fiddling with the time periods in Screensaver and Power Management was set the screen brightness in Power Management to 100% (it was 80%), but putting it back to 80% doesn't seem to cause any problems, so it doesn't seem to be an inherent problem of the system dealing with a partially bright screen. I can only imagine that a configuration file or process had become corrupt, and that either fiddling with settings more, a couple of normal reboots, or switching between ctrl+alt+F1/F7 when the problem occurred instead of a hard shut-down cleared out the problem... I can now watch videos without the screen going blank, and if I leave the computer unattended for the period of time specified in the Screensaver settings, xscreensaver starts up fine...

Thanks for your help and hard work looking at the forums to help new users such as me, and big thanks also to all the people who work on Ubuntu Mate and the distributions its based on.

Unfortunately, the problem has come back, after a day or so of working absolutely fine. Now it's consistently going to black screen again, as before. I had a look at the BIOS. There wasn't a setting there regarding energy saving and and the monitor. The closest was a "CPU Power Management" setting (enable/disable). I tried disabling this, but it had no effect. :frowning:

Update: several times it has got into the state when this bug occurs. I've found that putting the computer to sleep by closing the lid and then logging back in seems to reset things and get screensavers back to behaving normally. (Fully restarting doesn't have the same effect, though, for some reason.)

The last couple of times I've had the problem, I've noticed that shortly beforehand I've had an error message, and when it happened just now I did a screenshot. The message is: "Sorry, Ubuntu 18.04 has experienced an internal error." Looking down the error report, I see that the offending package is mate-dock-applet 0.85.1, which appears to have experienced a "crash."

I haven't figured out if there's something I'm doing in particular that causes the crash. I have MATE configured with the "mutiny" panel layout.

I believe that this is causing the problem. It's not too serious since I now know, as a workaround, that I can get out of the black screen with alt+ctrl+F1, then alt+ctrl+F7, and that I can then get rid of the problem by opening and closing the lid. However, if anyone can help me with advice to more properly fix the error, I would be grateful!


Did you check to make sure you don't have screensaver in settings set ?

Hi - thanks for you suggestion! I am not fully sure I understand it, but I did go into Control Center and look at both the Screensaver and Power Management panels, if that's what you mean. I've tried toggling on/off "Activate screensaver when computer is idle", as well as the various settings in these. I'm happy when the screensaver activates and works normally, which in fact it does most days, but when this problem occurs, it seems to short-circuit the screensaver. It's different from the screensaver as it happens even whilst videos are playing, and when you press a button the screen doesn't come back on, although sound suggests that the computer is still active behind the black screen...

I've also checked the BIOS settings, as suggested by ugvns above.

If there's another setting somewhere that I might need to look for, please do let me know where to find it!



I also have a Lenovo Thinkpad x250 and have begun to encounter this bug in 20.04.3 LTS. Have no idea why it's happening or what is causing it.

could it be like this ?

I started to have the same issue on a custom built pc for windows 7 ultimate. I installed Zorin 15. And After 15 min of inactivity the screen goes black and the sound works and the cursor moves.

However, ctrl+alt+f1 takes me to the terminal. Ctrl+alt f8 does not take me back to the desktop.

I've also made sure to disable screensaver since it never works. As well as power settings. All are set to do nothing.

Please advise. TIA!

Hi Jose, welcome to the community :slight_smile:

Ctrl-Alt-F1 to F6 takes you to several terminals indeed, but Ctrl-Alt-F7 brings you back to the desktop.

To prevent the screen from going blank:
Go to startup preferences (in control panel) and create an app by clicking the add button.

Name: Stop Screen Blanking
command: xset -dpms s off s noblank s 0 0 s noexpose
comments: This prevents the screen from going blank.
Delay: 0

Hope this helps :slight_smile:


For my wife's Qosmio laptop, functions like what you described are controlled by a vendor supplied application (under Windows OS). Interestingly enough those functions are not accessible from Windows itself. So, I wonder if that is similar to what you are experiencing? It might be interesting to contact the hardware manufacturer to ask if they have "Linux-friendly" staff that might offer assistance with a similar tool. Just a thought.

Champion :+1: Thank you