Problem with Magnet link when downloading Ubuntu Mate


#1

Hello,
I just noticed an issue on the Ubuntu Mate website: when downloading the distro (I’ve tried only 16.10 64 bit, might happen with other versions too) using BitTorrent, the Magnet link opens a torrent with no tracker associated, so no sources, so no download possible unless I add a tracker manually in Transmission. Downloading the .torrent file and opening it manually in Transmission works fine, the issue happens only with the Magnet link.


#2

Hi @terzag,

have you tried using a direct http download link?. :smiley:


#3

The direct link works, the .torrent file works, the issue is only with the Magnet link. I don’t have trouble downloading Mate, I’m only reporting the issue so it can be fixed and not confuse future downloaders. :wink:


#4

Okay, call attention to @wimpy as he is the man!. :smiley:


#5

It’s due to how the magnet links are (automatically) generated, it’s normal there’s no trackers in this case.

Torrents don’t need trackers… So once added to the client, it will eventually start to download.


#6

That’s weird as 1) it didn’t start to download or even find sources and after a while I wondered why, I checked the properties, saw there were no trackers, added the right one (tracker.ubuntu.com) and it started finding sources; and 2) when I add a torrent via a Magnet link from other websites, it has a list of trackers.