Okay, so just to let you guys and gals know, this is a bit of a winge, so you can turn over the page at this point if you wish…

Until recently, I was using UM 14.04. However, following the introduction of UM 16.04, I thought I would give it a go. But, since installing it there have been a number of minor and one major issue that have led me, for the moment at least, to choose to go back to UM 14.04. These are:

The version of Caffeine I use is not working any more - Caffeine, as many of you may know, is a screen-saver inhibitor that allows you to choose (or, at least, the older versions of it did) which applications, if they are currently running, may cause the screen-saver to be inhibited. I always have this installed and use VLC, Chromium and Firefox as the trigger apps. There is a newer version of Caffeine in the repos. But this is inferior, in my opinion, because it only inhibits on the basis of certain types of video running in full-screen and does not allow one to arbitrarily choose which specific apps inhibit the screen-saver The very latest version has brought some of the old functionality back. But, it runs very flaky and inconsistently now. So, all in all, I have always installed the older version that just works. This version, if anyone is interested, is: caffeine_2.5.1+546~behda~ubuntu13.10.1_all.deb. However, as I said, in UM 16.04, this older version has stopped working. So I am now left, for the moment, without an effective screen-saver inhibitor which, although not a show-stopper, is a bit of an irritation since I ordinarily use it on various machines for multimedia streaming purposes.

Arios Automount is not working any more - Arios Automount is an old GUI based program that will automatically mount any and all partitions and drives at boot-up without needing to touch fstab. This automatic mounting is, for a variety of reasons, something I need to happen. This is also handy for me since I am always swapping external drives about and don’t want to be having to constantly go into fstab and edit it to reflect these changes. Arios Automount just wont work in 16.04. Again, not a show stopper, but another irritation nonetheless.

Mintstick is not working any more - I am sure most of you will be aware that Mintstick is the excellent app by the Linux Mint team that allows you to format USBs and also set them up as bootable USB ISOs. I have always used this as it is, simply, superior both in terms of effectiveness and ease of use than any other similar app. Again, this has just stopped working in UM 16.04. I know there are alternatives, but they are, frankly, not as good by far. Again, not a show stopper in itself. But, the irritations are starting to accumulate.

LTSP is not working any more - LTSP is a terminal server set-up that allows thin and thick clients to run exclusively from a server, with the clients machines not needing an OS installation or, even, a drive of their own. I use this round my house on various machines and it makes for easy maintenance of them and also in terms of pushing out any new features. I first started using this in Ubuntu 12.04. It stopped working in Ubuntu 13 onwards, so I stuck with 12.04. Until, that is, one of the regular software updates broke it!. At which point, I was stuck without it for a while. Then, when UM 14.04 came along, I was so impressed I installed it and, after much trial and tribulation, I managed to a get a version of LTSP, called PNP LTSP, installed and working well. Until, that is, another one of the regular software updates broke it again! In desperation, I then went to the only version of Ubuntu that has a working LTSP set-up out of the box, Edubuntu 14.04, and used that until very recently. Basically it consisted of Edubuntu 14.04 with Unity stripped out and with Ubuntu Mate desktop installed. It was a bit of a hassle to set up. But, once set up, it was essentially UM 14.04, but with a working LTSP. In UM 16.04, I simply cannot get any version of LTSP to work. Nor can I use Edubuntu 16.04 and install UM desktop over the top because Edubuntu has, for the moment at least, been discontinued at 14.04. So, with UM 16.04, I currently do not have LTSP. This is a much more significant hassle than those previously.

The CPUs on my machine are running far hotter than previously - When I was using UM 14.04, the CPU idle temperature was typically in the very low 30s. Since installing UM 16.04, however, the idle temperature is never below the early 40s and is often in the late 40s/early 50s. Occasionally, even, it seems to have a significant wobble and fly up into the late 60s or even early 70s even though it is supposedly idle, and stubbornly remain there. When I check on my system monitor, it shows that at least one or two of my cores is running flat out at 100% and this 100% usage then dances around from core to core. The only solution being to log out and then back in. At which point, it drops back to a more tolerable early 40s and my cores read as normal idle usage of 2 or 3 percent. I have objectively compared this by running both 14.04 and 16.04 on the same machine and the difference is both consistent and significant. This is a more serious issue. I am unsure what is causing it, but I do wonder if it may be related to my next item.

AMD R7200 GPU cannot utilize propriety drivers any more - As has been flagged up on this forum and elsewhere, the AMD propriety fglrx driver is not usable in UM 16.04. Nevertheless, I thought I wold give 16.04 a go with the open source drivers. for the most part, they are okay, if a bit more sluggish than the proprietary ones. However, there are two regards where their impaired performance is more significant. Firstly, from what i have read, Steam will not work with the open source drivers. I have a few steam apps I like to run, so this is a bit of a pain for me. Secondly, I use Blender a lot. It turns out that a number of editing functions in Blender run badly with the open source driver as compared to the propriety one. Again, I have tested this by comparison with 14.04 with the proprietary driver and 16.04 without it. The difference is both consistent and significant.

Taking all of the above into account I decided, yesterday, to go back to Edubuntu 14.04 (with UM desktop) for a while. Then work on setting up a tolerable 16.04 on a test rig in the interim. So, after a few hours of setting it all up, including stripping out all of the Unity crap, installing UM desktop, getting rid of other Ubuntu apps that were duplicated with UM, I got it all set up with the propriety GPU driver. All seemed well at this point. So, feeling very satisfied with myself, I went into the kitchen to make a coffee.

However, upon my return, I fond my desktop completely frozen. I was forced to cold re-boot. At which point all seemed well again. Until about 1/2 an hour later when it happened again. This kept happening. I then, as an experiment, went back to the open source driver and, guess what? The screen freeze stopped immediately! So, the conclusion I began to draw at this point, given the assumption that the flgrx drivers are unchanged, is that Canonical, somewhere in its bloody damned updates, has buggered 14.04’s capacity to utilize the fglrx driver as well as 16.04!

To test the above hypothesis out, I installed a fresh copy of UM 14.04. Sure enough, the same damned problem with screen freeze when using the flgrx driver.

So now, I have the following choices:

UM 16.04 with no LTSP, no automatic partition mounter, no adequate screen-saver inhibitor, no adequate USB creator, the cores running way too hot and no propriety drivers for the GPU


Edubuntu 14.04 (with UM desktop) with no propriety drivers for the GPU

Not happy

At all

The overheating problem is probably triggered by the gvfsd-smb bug.
Let’s hope that’ll get fixed by 16.04.1

Thanks for that info ouroumov. Also, after spotting the three letters “smb”, in your post reminded me that I forgot to mention that Samba is not behaving itself properly either in UM 16.04

Hi @stevecook172001, a little tip to save you a few hours in future is to use Clonezilla Live to create an image of your system when it’s working. It would surely save the hassle everything up again by rolling back to a time when the system “worked fine”.

I always do this on my desktop and netbook before upgrades – I wish I did for this other machine, 16.04 introduced a screen resolution problem (on-board AMD, same under both drivers)… Only after having re-installing 15.10 fresh to find out it was the VGA cable loose at the back. :frowning:

I’ve always chosen NVIDIA card for graphics… I don’t see AMD’s drivers as very reliable, but we’ll see in the summer if their new driver delivers well.

Thanks lah7, but I already use Clonezilla. The problem has been in the ongoing updates. Unless, I know precisely which update is the culprit on any given occasion (which I don’t), I am compelled to let them all through in case some of them may be system critical. Though, I do think your idea of taking a clone immediately prior to an upgrade is a good idea and will do that in future. Typically, I have only hitherto, taken a clone immediately following installation when the system was at it’s cleanest and simplest.

1 Like

Hi Steve,

change your software sources download location and then try running the following terminal command (Ctrl + Alt + t) which might help solve a couple of your problems?:

sudo apt-get update && sudo apt-get dist-upgrade -f

See also:

Why will changing sources solve the problems?

Hi Steve,

problem software often gets updated quicker on other servers than the one you are using, a good example was a fresh install of a friends laptop with UM 16.04 and a few niggling problems with browser speed yesterday, I changed the download location from Germany to “Main server” and did a restart and the problems were solved!. :thumbsup:

I see what you are getting at Wolfman. But, so far as the programs that no longer run are concerned, this is, I suspect, not due to an “error” or “temporary omission” in the updates. Rather, it is a change of the way that the system is designed to run such that these various programs simply wont work in the new environment. As for LTSP, this has been a perennial problem on and off with Ubuntu and so, again, is unlikely to be fixed by simply changing repository location. Regarding the overly hot cores, again, this seems to stem, from what I have read, from a Debian bug that will, in due course, hopefully be fixed. Until then, it isn’t going to matter, save for gaining or losing a few days, what repository location is used. The same is also true for the samba nonsense that is currently occurring on 16.04. Finally, the issue with my AMD GPU is one of there simply being no flgrx driver currently available for 16.04.

1 Like

I just discovered that AMD have their new driver in beta for Ubuntu 16.04… but sadly, it’s not ready for your AMD R7200 GPU yet. Your card is planned for support though… just

:scissors: Snip from article:

Bear in mind that this driver isn’t yet compatible with anywhere near as many AMD graphics processors as the older driver is. At the moment, AMD says the driver is only compatible with AMD Radeon R9 Fury X, R9 Fury, R9 Nano, R9 M395X, R9 380X, R9 380, and R9 285 graphics processors.

Eventually, AMD plans to support hardware going back to the GCN 1.0 “Southern Islands” GPUs—that’s the Radeon HD 7000 series and newer. Older hardware won’t be supported with the AMDGPU driver.


I think Gnome Disks can automount partitions for you. It’s Gnome design so it’s not very intuitive, but I think it gives you all the options you need.

I have never tried Mintstick. UNetbootin from PPA always did the trick for me.
Only downside is that you have to use another application like Gparted to format your USB. I will check out Mintstick and maybe steal it from my LM 17 installation. I’m on UM 14.04.

I have had working fglrx driver in Linux Mint 17. If it doesn’t work anymore it’s a shame. Have you tried both fglrx-stable and fglrx-updates?

I’ve used Gnome Disks. But, it is inferior in my opinion in a number of respects. Firstly, I have found the the auto-mount function sometime just simply does not work for reasons unknown. Also, although Martin recommends Disks as an alternative for usb creation, it also is a pain here as well because, following setting up a bootable usb with it, if one wants to later reuse the disk for another live iso, one has to go and completely erase the partition on it in something like Gparted. And it complains like hell while that is happening, again for reasons unknown.

As for Mintstick, it simply is the best of this type of program there is. And I have tried tham all, including the one you mention. I fully accept there are alternatives to Minstick. But with the exception of the old reliable terminal dd command, they are all a pretty flaky by comparison.

As for fglrx drivers not working in 14.04 now; I can confirm, at least on both Ubuntu Mate 14.04 and Edubuntu 14.04, that flgrx is no longer working and I am forced to use the open source driver. So, whatever the hell that is in 16.04 that has made it impossible for the fglrx driver to work has been back-ported (or whatever term that is used) to 14.04. So, 14.04 is now equally buggered in terms of flgrx.

Anyway, I have downgraded to Edubuntu 14.04, stripped out all of Unity and have installed Ubuntu Mate 1.8 desktop. All of the programs I mentioned are now working again, including LTSP. The only thing that is still an issue is the fact of having to use the open source AMD GPU driver. But, i shall have to live with that until AMD come out with their new driver and/or I put my hand in my pocket and fork out for a new Nvidia GPU.

1 Like

Oh, and just to add insult to bloody injury…

The crap with Samba that has infected Ubuntu 16.04 has ALSO been back-ported to 14.04!