Problems typing Portuguese characters

I’m having trouble typing certain special Portuguese characters in Ubuntu MATE 16.04 LTS. I’m running it live from an USB pendrive, before I finally install it, but unfortunately I really need correct orthography and so I can’t ignore this issue.

I’ve already tried changing my Keyboard Layout to Portuguese (Brazil), I’ve tried changing the system’s language settings for Portuguese (and I’ve also tried enabling/disabling the different keyboard input methods such as fcitx, iBus and XIM). It seems it doesn’t matter what I do, I can’t type the characters that would require either using a dead key or the compose key (oh, I’ve also tried changing the compose key settings, that too wouldn’t work).

The end result looks like this: “~a” instead of “ã”, “´e” instead of “é”, and so on. What should I do?

Thanks in advance!

1 Like

Hi @zarnistrelli,

open Control Centre > Hardware > Keyboard > Layouts and add "Portuguese" again and remove the other keyboard showing in the list, then test it and see if that helps?:

What are your language settings like?:

What about updates?:

@wolfman Thanks for helping me out! I tried that too, though, and it didn’t work :confused: I guess I should make it clear that with the “Portuguese (Brazil)” layout the keys are all in the right places, so to say, which means pressing them produces the characters printed on them! My specific problem is that the tilde “~”, the circunflex accent “^”, the acute accent “’” and the grave accent “`” won’t behave as dead keys and also the compose key won’t work, so I can’t place those accents over any letters.

Regarding my language settings, I changed both of the panels (the main one and the “Regional” one) to Portuguese (Brazil), but given I was using Ubuntu Mate live from a pendrive, I didn’t actually restart the computer to apply the changes. Further, I tried changing the Keyboard Input settings from “fcitk” to “XIM” to “none” and I even tried installing “iBus” through Terminal but, alas, none of that solved my problem.

Again, thanks for your help (and Happy New Year! A great 2017 for you all! :tada:)

1 Like

Click where it states "Keyboard model" and see if the exact name of your keyboard is in the list, keep testing in the panel below until you strike lucky!:

There is also Portuguese and Brazil, are there any differences?:

You can also click on "Variants" and see if you can find something there!. :smiley:

Happy New Year to you and your family. :smiley:

@wolfman When I posted here first I had already tried all of that! I did find a keyboard layout which is practically the same as my own (Dell Inspiron something, can’t quite remember right now), but even then the issue persists. As I said, the keys are correctly mapped, they produce the characters actually printed on them, it’s just that the accents are treated as if they were characters per se (pressing the tilde produces ~ instead of allowing me to then type another letter and have ã or õ). I had Portuguese (Brazil) first selected, too (and not Portuguese Portuguese). Any keyboard variants other than that get the keys to become misplaced, as they won’t behave as what’s printed on top of them.

I’m on mobile right now, though, so it’s a bit of a confusion here, and I just saw that your first answer had other posts linked in it, so I’ll read through them and see if I can find something useful!

Thanks again!


Hi @zarnistrelli,

just another thought for you, have you tried "Onboard"?.

Applications > Universal Access > Onboard:

(German layout).

Happy New Year. :smiley:

Hi @zarnistrelli,
Have you come across any solution? I have been facing the same problem here.

1 Like

Sorry the late answer, but I had this issue after a new Ubuntu Mate 16.04 install.

I found an answer here

First install ibus:
sudo apt-get install ibus

Then add the “ibus-daemon --xim” as Startup Application in order to forget this issue forever.

1 Like